summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/apu_config_dont_list_indep_libs.patch35
-rw-r--r--debian/patches/avoid_db_by-default.patch35
-rw-r--r--debian/patches/avoid_ldap_by_defaut.patch34
-rw-r--r--debian/patches/buildconf_config.guess_sub_location.patch22
-rw-r--r--debian/patches/configure_in_remove_syspaths.patch20
-rw-r--r--debian/patches/dbm_read_hash_or_btree.patch33
-rw-r--r--debian/patches/debian_layout_fix.patch16
-rw-r--r--debian/patches/dont_use_all_pg_build_deps.patch61
-rw-r--r--debian/patches/doxygen_no_ful_path_names.patch12
-rw-r--r--debian/patches/fix_doxygen_inputdir12
-rw-r--r--debian/patches/series11
-rw-r--r--debian/patches/test_verbose13
12 files changed, 304 insertions, 0 deletions
diff --git a/debian/patches/apu_config_dont_list_indep_libs.patch b/debian/patches/apu_config_dont_list_indep_libs.patch
new file mode 100644
index 0000000..d9e6e2f
--- /dev/null
+++ b/debian/patches/apu_config_dont_list_indep_libs.patch
@@ -0,0 +1,35 @@
+From: Peter Samuelson <peter@p12n.org>
+Subject: Prevent recursive linking of dependent libraries by apr-util users.
+
+---
+ apr-util.pc.in | 5 +++--
+ apu-config.in | 2 +-
+ 2 files changed, 4 insertions(+), 3 deletions(-)
+
+Index: trunk/apr-util.pc.in
+===================================================================
+--- trunk.orig/apr-util.pc.in
++++ trunk/apr-util.pc.in
+@@ -8,6 +8,7 @@
+ Description: Companion library for APR
+ Version: @APRUTIL_DOTTED_VERSION@
+ # assume that apr-util requires libapr of same major version
+-Requires: apr-@APRUTIL_MAJOR_VERSION@
+-Libs: -L${libdir} -l@APRUTIL_LIBNAME@ @LDADD_ldap@ @APRUTIL_EXPORT_LIBS@
++Requires.private: apr-@APRUTIL_MAJOR_VERSION@
++Libs: -L${libdir} -l@APRUTIL_LIBNAME@ @LDADD_ldap@
++Libs.private: @APRUTIL_EXPORT_LIBS@
+ Cflags: -I${includedir}
+Index: trunk/apu-config.in
+===================================================================
+--- trunk.orig/apu-config.in
++++ trunk/apu-config.in
+@@ -27,7 +27,7 @@
+ libdir="@libdir@"
+ includedir="@includedir@"
+
+-LIBS="@APRUTIL_EXPORT_LIBS@"
++LIBS=
+ INCLUDES="@APRUTIL_INCLUDES@"
+ LDFLAGS="@APRUTIL_LDFLAGS@"
+ ORIG_LDAP_LIBS="@LDADD_ldap@"
diff --git a/debian/patches/avoid_db_by-default.patch b/debian/patches/avoid_db_by-default.patch
new file mode 100644
index 0000000..712935c
--- /dev/null
+++ b/debian/patches/avoid_db_by-default.patch
@@ -0,0 +1,35 @@
+From: Stefan Fritsch <sf@debian.org>
+Subject: Make apu-config not output dbm libs by default. See #622081
+
+--- apr-util.orig/apu-config.in
++++ apr-util/apu-config.in
+@@ -32,7 +32,8 @@ INCLUDES="@APRUTIL_INCLUDES@"
+ LDFLAGS="@APRUTIL_LDFLAGS@"
+ ORIG_LDAP_LIBS="@LDADD_ldap@"
+ LDAP_LIBS=""
+-DBM_LIBS="@LDADD_dbm_db@ @LDADD_dbm_gdbm@ @LDADD_dbm_ndbm@"
++ORIG_DBM_LIBS="@LDADD_dbm_db@ @LDADD_dbm_gdbm@ @LDADD_dbm_ndbm@"
++DBM_LIBS=""
+
+ APRUTIL_LIBNAME="@APRUTIL_LIBNAME@"
+
+@@ -58,8 +59,8 @@ Known values for OPTION are:
+ --libs print library information
+ --avoid-ldap do not include ldap library information with --libs (default on Debian)
+ --ldap-libs print library information to link with ldap
+- --avoid-dbm do not include DBM library information with --libs
+- --dbm-libs print additional library information to link with DBM
++ --avoid-dbm do not include DBM library information with --libs (default on Debian)
++ --dbm-libs print library information to link with DBM
+ --srcdir print APR-util source directory
+ --link-ld print link switch(es) for linking to APR-util
+ --link-libtool print the libtool inputs for linking to APR-util
+@@ -125,7 +126,7 @@ while test $# -gt 0; do
+ flags="$flags $ORIG_LDAP_LIBS"
+ ;;
+ --dbm-libs)
+- flags="$flags $DBM_LIBS"
++ flags="$flags $ORIG_DBM_LIBS"
+ ;;
+ --includedir)
+ if test "$location" = "installed"; then
diff --git a/debian/patches/avoid_ldap_by_defaut.patch b/debian/patches/avoid_ldap_by_defaut.patch
new file mode 100644
index 0000000..d3377d9
--- /dev/null
+++ b/debian/patches/avoid_ldap_by_defaut.patch
@@ -0,0 +1,34 @@
+From: Ryan Niebur <ryanryan52@gmail.com>
+Subject: by default --avoid-ldap since apache2 is the only user, and we don't
+ want to add extra dependencies to other apr-utils rdepends
+
+--- apr-util.orig/apu-config.in
++++ apr-util/apu-config.in
+@@ -30,7 +30,8 @@ includedir="@includedir@"
+ LIBS="@APRUTIL_EXPORT_LIBS@"
+ INCLUDES="@APRUTIL_INCLUDES@"
+ LDFLAGS="@APRUTIL_LDFLAGS@"
+-LDAP_LIBS="@LDADD_ldap@"
++ORIG_LDAP_LIBS="@LDADD_ldap@"
++LDAP_LIBS=""
+ DBM_LIBS="@LDADD_dbm_db@ @LDADD_dbm_gdbm@ @LDADD_dbm_ndbm@"
+
+ APRUTIL_LIBNAME="@APRUTIL_LIBNAME@"
+@@ -55,7 +56,7 @@ Known values for OPTION are:
+ --includedir print location where headers are installed
+ --ldflags print linker flags
+ --libs print library information
+- --avoid-ldap do not include ldap library information with --libs
++ --avoid-ldap do not include ldap library information with --libs (default on Debian)
+ --ldap-libs print library information to link with ldap
+ --avoid-dbm do not include DBM library information with --libs
+ --dbm-libs print additional library information to link with DBM
+@@ -121,7 +122,7 @@ while test $# -gt 0; do
+ flags="$flags $LDAP_LIBS $DBM_LIBS $LIBS"
+ ;;
+ --ldap-libs)
+- flags="$flags $LDAP_LIBS"
++ flags="$flags $ORIG_LDAP_LIBS"
+ ;;
+ --dbm-libs)
+ flags="$flags $DBM_LIBS"
diff --git a/debian/patches/buildconf_config.guess_sub_location.patch b/debian/patches/buildconf_config.guess_sub_location.patch
new file mode 100644
index 0000000..366c147
--- /dev/null
+++ b/debian/patches/buildconf_config.guess_sub_location.patch
@@ -0,0 +1,22 @@
+From: Tollef Fog Heen <tfheen@debian.org>
+Subject: Adjust path of config.guess and config.sub
+
+---
+ buildconf | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: trunk/buildconf
+===================================================================
+--- trunk.orig/buildconf
++++ trunk/buildconf
+@@ -61,8 +61,8 @@
+ rm -f build/apr_common.m4 build/find_apr.m4 build/install.sh \
+ build/config.guess build/config.sub build/get-version.sh
+ cp -p $apr_src_dir/build/apr_common.m4 $apr_src_dir/build/find_apr.m4 \
+- $apr_src_dir/build/install.sh $apr_src_dir/build/config.guess \
+- $apr_src_dir/build/config.sub $apr_src_dir/build/get-version.sh \
++ $apr_src_dir/build/install.sh /usr/share/misc/config.guess \
++ /usr/share/misc/config.sub $apr_src_dir/build/get-version.sh \
+ build/
+
+ # Remove aclocal.m4 as it'll break some builds...
diff --git a/debian/patches/configure_in_remove_syspaths.patch b/debian/patches/configure_in_remove_syspaths.patch
new file mode 100644
index 0000000..9df3437
--- /dev/null
+++ b/debian/patches/configure_in_remove_syspaths.patch
@@ -0,0 +1,20 @@
+From: Tollef Fog Heen <tfheen@debian.org>
+Subject: Adjust LDFLAGS and INCLUDE
+
+
+---
+ configure.in | 3 +++
+ 1 file changed, 3 insertions(+)
+
+--- apr-util.orig/configure.in
++++ apr-util/configure.in
+@@ -280,6 +280,9 @@ dnl Prep all the flags and stuff for com
+ dnl
+ APR_ADDTO(APRUTIL_LIBS, [$APR_LIBS])
+
++APR_REMOVEFROM(APRUTIL_LDFLAGS, [-L/usr/lib])
++APR_REMOVEFROM(APRUTIL_INCLUDE, [-I/usr/include])
++
+ AC_SUBST(APRUTIL_EXPORT_LIBS)
+ AC_SUBST(APRUTIL_PRIV_INCLUDES)
+ AC_SUBST(APRUTIL_INCLUDES)
diff --git a/debian/patches/dbm_read_hash_or_btree.patch b/debian/patches/dbm_read_hash_or_btree.patch
new file mode 100644
index 0000000..cdaee76
--- /dev/null
+++ b/debian/patches/dbm_read_hash_or_btree.patch
@@ -0,0 +1,33 @@
+From: Adam Conrad <adconrad@0c3.net>
+Subject: Be more liberal in the types of DBM files we accept.
+
+---
+ dbm/apr_dbm_berkeleydb.c | 15 +++++++++++++++
+ 1 file changed, 15 insertions(+)
+
+Index: trunk/dbm/apr_dbm_berkeleydb.c
+===================================================================
+--- trunk.orig/dbm/apr_dbm_berkeleydb.c
++++ trunk/dbm/apr_dbm_berkeleydb.c
+@@ -174,6 +174,21 @@
+ apr_posix_perms2mode(perm))) != 0) {
+ /* close the DB handler */
+ (void) (*file.bdb->close)(file.bdb, 0);
++ if (dberr == EINVAL) {
++ if ((dberr = db_create(&file.bdb, NULL, 0)) == 0) {
++ if ((dberr = (*file.bdb->open)(file.bdb,
++#if DB_VER == 4
++ NULL,
++#endif
++ pathname, NULL,
++ DB_BTREE, dbmode,
++ apr_posix_perms2mode(perm))) != 0) {
++
++ /* close the DB handler */
++ (void) (*file.bdb->close)(file.bdb, 0);
++ }
++ }
++ }
+ }
+ }
+ file.curs = NULL;
diff --git a/debian/patches/debian_layout_fix.patch b/debian/patches/debian_layout_fix.patch
new file mode 100644
index 0000000..861a9b4
--- /dev/null
+++ b/debian/patches/debian_layout_fix.patch
@@ -0,0 +1,16 @@
+From: <tfheen@debian.org>
+Subject: Fix the includedir in the Debian layout.
+
+Index: trunk/config.layout
+===================================================================
+--- trunk.orig/config.layout
++++ trunk/config.layout
+@@ -223,7 +223,7 @@
+ libexecdir: ${exec_prefix}/lib/apr/modules
+ mandir: ${exec_prefix}/share/man
+ datadir: ${exec_prefix}/share/apr
+- includedir: ${exec_prefix}/include/apr-${APRUTIL_MAJOR_VERSION}
++ includedir: ${exec_prefix}/include/apr-1.0
+ localstatedir: ${prefix}/var/run
+ runtimedir: ${prefix}/var/run
+ infodir: ${exec_prefix}/share/info
diff --git a/debian/patches/dont_use_all_pg_build_deps.patch b/debian/patches/dont_use_all_pg_build_deps.patch
new file mode 100644
index 0000000..5692fb8
--- /dev/null
+++ b/debian/patches/dont_use_all_pg_build_deps.patch
@@ -0,0 +1,61 @@
+From: Ryan Niebur <RyanRyan52@gmail.com>
+Subject: Link directly to postgresql
+
+Index: trunk/build/dbd.m4
+===================================================================
+--- trunk.orig/build/dbd.m4
++++ trunk/build/dbd.m4
+@@ -44,7 +44,7 @@
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1],[
+ if test "x$PGSQL_CONFIG" != 'x'; then
+ unset ac_cv_lib_pq_PQsendQueryPrepared
+- pgsql_LIBS="`$PGSQL_CONFIG --libs`"
++ pgsql_LIBS="-lpq"
+ APR_ADDTO(LIBS, [$pgsql_LIBS])
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1])
+ fi
+@@ -55,7 +55,7 @@
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1],[
+ if test "x$PGSQL_CONFIG" != 'x'; then
+ unset ac_cv_lib_pq_PQsendQueryPrepared
+- pgsql_LIBS="`$PGSQL_CONFIG --libs`"
++ pgsql_LIBS="-lpq"
+ APR_ADDTO(LIBS, [$pgsql_LIBS])
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1])
+ fi
+@@ -85,7 +85,7 @@
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1],[
+ if test "x$PGSQL_CONFIG" != 'x'; then
+ unset ac_cv_lib_pq_PQsendQueryPrepared
+- pgsql_LIBS="`$PGSQL_CONFIG --libs`"
++ pgsql_LIBS="-lpq"
+ APR_ADDTO(LIBS, [$pgsql_LIBS])
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1])
+ fi
+@@ -96,7 +96,7 @@
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1],[
+ if test "x$PGSQL_CONFIG" != 'x'; then
+ unset ac_cv_lib_pq_PQsendQueryPrepared
+- pgsql_LIBS="`$PGSQL_CONFIG --libs`"
++ pgsql_LIBS="-lpq"
+ APR_ADDTO(LIBS, [$pgsql_LIBS])
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1])
+ fi
+@@ -121,7 +121,7 @@
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1],[
+ if test "x$PGSQL_CONFIG" != 'x'; then
+ unset ac_cv_lib_pq_PQsendQueryPrepared
+- pgsql_LIBS="`$PGSQL_CONFIG --libs`"
++ pgsql_LIBS="-lpq"
+ APR_ADDTO(LIBS, [$pgsql_LIBS])
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1])
+ fi
+@@ -132,7 +132,7 @@
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1],[
+ if test "x$PGSQL_CONFIG" != 'x'; then
+ unset ac_cv_lib_pq_PQsendQueryPrepared
+- pgsql_LIBS="`$PGSQL_CONFIG --libs`"
++ pgsql_LIBS="-lpq"
+ APR_ADDTO(LIBS, [$pgsql_LIBS])
+ AC_CHECK_LIB(pq, PQsendQueryPrepared, [apu_have_pgsql=1])
+ fi
diff --git a/debian/patches/doxygen_no_ful_path_names.patch b/debian/patches/doxygen_no_ful_path_names.patch
new file mode 100644
index 0000000..7c2e151
--- /dev/null
+++ b/debian/patches/doxygen_no_ful_path_names.patch
@@ -0,0 +1,12 @@
+# FULL_PATH_NAMES breaks reproducible builds
+--- apr-util.orig/docs/doxygen.conf
++++ apr-util/docs/doxygen.conf
+@@ -24,7 +24,7 @@ PREDEFINED="APU_DECLARE(x)=x" \
+
+ OPTIMIZE_OUTPUT_FOR_C=YES
+
+-FULL_PATH_NAMES=YES
++FULL_PATH_NAMES=NO
+ CASE_SENSE_NAMES=NO
+ # some autoconf guru needs to make configure set this correctly...
+ #STRIP_FROM_PATH=/root/apache/httpd-2.0-8/srclib/apr-util
diff --git a/debian/patches/fix_doxygen_inputdir b/debian/patches/fix_doxygen_inputdir
new file mode 100644
index 0000000..965e0f2
--- /dev/null
+++ b/debian/patches/fix_doxygen_inputdir
@@ -0,0 +1,12 @@
+Index: apr-util/docs/doxygen.conf
+===================================================================
+--- apr-util.orig/docs/doxygen.conf
++++ apr-util/docs/doxygen.conf
+@@ -1,6 +1,6 @@
+ PROJECT_NAME="Apache Portable Runtime Utility Library"
+
+-INPUT=.
++INPUT=../../include include
+ QUIET=YES
+ RECURSIVE=YES
+ FILE_PATTERNS=*.h
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..35fd85d
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,11 @@
+dbm_read_hash_or_btree.patch
+configure_in_remove_syspaths.patch
+buildconf_config.guess_sub_location.patch
+debian_layout_fix.patch
+dont_use_all_pg_build_deps.patch
+avoid_ldap_by_defaut.patch
+apu_config_dont_list_indep_libs.patch
+avoid_db_by-default.patch
+test_verbose
+fix_doxygen_inputdir
+doxygen_no_ful_path_names.patch
diff --git a/debian/patches/test_verbose b/debian/patches/test_verbose
new file mode 100644
index 0000000..b66201d
--- /dev/null
+++ b/debian/patches/test_verbose
@@ -0,0 +1,13 @@
+Index: apr-util/test/Makefile.in
+===================================================================
+--- apr-util.orig/test/Makefile.in 2012-08-13 20:45:30.000000000 +0200
++++ apr-util/test/Makefile.in 2013-11-01 19:35:02.439372134 +0100
+@@ -74,7 +74,7 @@
+ done; \
+ else \
+ @apr_shlibpath_var@="`echo "../crypto/.libs:../dbm/.libs:../dbd/.libs:../ldap/.libs:$$@apr_shlibpath_var@" | sed -e 's/::*$$//'`" \
+- ./$$prog; \
++ ./$$prog -v ; \
+ status=$$?; \
+ if test $$status != 0; then \
+ teststatus=$$status; \