summaryrefslogtreecommitdiffstats
path: root/t/dh_installpam
diff options
context:
space:
mode:
Diffstat (limited to 't/dh_installpam')
-rw-r--r--t/dh_installpam/debian/changelog5
-rw-r--r--t/dh_installpam/debian/control10
-rw-r--r--t/dh_installpam/debian/foo.pam1
-rwxr-xr-xt/dh_installpam/dh_installpam.t38
4 files changed, 54 insertions, 0 deletions
diff --git a/t/dh_installpam/debian/changelog b/t/dh_installpam/debian/changelog
new file mode 100644
index 0000000..5850f0e
--- /dev/null
+++ b/t/dh_installpam/debian/changelog
@@ -0,0 +1,5 @@
+foo (1.0-1) unstable; urgency=low
+
+ * Initial release. (Closes: #XXXXXX)
+
+ -- Test <testing@nowhere> Mon, 11 Jul 2016 18:10:59 +0200
diff --git a/t/dh_installpam/debian/control b/t/dh_installpam/debian/control
new file mode 100644
index 0000000..c266f51
--- /dev/null
+++ b/t/dh_installpam/debian/control
@@ -0,0 +1,10 @@
+Source: foo
+Section: misc
+Priority: optional
+Maintainer: Test <testing@example.org>
+Standards-Version: 3.9.8
+
+Package: foo
+Architecture: all
+Description: package foo
+ Package foo
diff --git a/t/dh_installpam/debian/foo.pam b/t/dh_installpam/debian/foo.pam
new file mode 100644
index 0000000..fab1c8c
--- /dev/null
+++ b/t/dh_installpam/debian/foo.pam
@@ -0,0 +1 @@
+@include common-auth
diff --git a/t/dh_installpam/dh_installpam.t b/t/dh_installpam/dh_installpam.t
new file mode 100755
index 0000000..4e76799
--- /dev/null
+++ b/t/dh_installpam/dh_installpam.t
@@ -0,0 +1,38 @@
+#!/usr/bin/perl
+use strict;
+use warnings;
+
+use Test::More;
+use File::Basename qw(dirname);
+use lib dirname(dirname(__FILE__));
+use Test::DH;
+use File::Path qw(make_path);
+use Debian::Debhelper::Dh_Lib qw(!dirname);
+
+plan(tests => 2);
+
+our @TEST_DH_EXTRA_TEMPLATE_FILES = (qw(
+ debian/changelog
+ debian/control
+ debian/foo.pam
+));
+
+each_compat_up_to_and_incl_subtest(13, sub {
+ make_path(qw(debian/foo));
+ ok(run_dh_tool('dh_installpam'));
+
+ ok(-f 'debian/foo/etc/pam.d/foo');
+ ok(! -f 'debian/foo/usr/lib/pam.d/foo');
+
+ ok(run_dh_tool('dh_clean'));
+});
+
+each_compat_from_and_above_subtest(14, sub {
+ make_path(qw(debian/foo));
+ ok(run_dh_tool('dh_installpam'));
+
+ ok(! -f 'debian/foo/etc/pam.d/foo');
+ ok(-f 'debian/foo/usr/lib/pam.d/foo');
+
+ ok(run_dh_tool('dh_clean'));
+});