summaryrefslogtreecommitdiffstats
path: root/pydist/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /pydist/Makefile
parentInitial commit. (diff)
downloaddh-python-ba6d96469df143b52295f8e79da648bf8a597407.tar.xz
dh-python-ba6d96469df143b52295f8e79da648bf8a597407.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pydist/Makefile')
-rw-r--r--pydist/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/pydist/Makefile b/pydist/Makefile
new file mode 100644
index 0000000..2932a45
--- /dev/null
+++ b/pydist/Makefile
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+FALLBACK_FLAGS = $(shell dpkg-vendor --is ubuntu && echo '--ubuntu')
+
+all: cpython3_fallback README.PyDist.html
+
+clean:
+ rm -rf cache
+ #rm -f dist_fallback
+ rm -f README.PyDist.html
+
+cpython3_fallback:
+ python3 ./generate_fallback_list.py $(FALLBACK_FLAGS)
+
+README.PyDist.html: README.PyDist
+ rst2html $< $@
+
+.PHONY: clean