summaryrefslogtreecommitdiffstats
path: root/tests/t301
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/t301
parentInitial commit. (diff)
downloaddh-python-upstream.tar.xz
dh-python-upstream.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t301')
-rw-r--r--tests/t301/Makefile15
-rw-r--r--tests/t301/debian/changelog5
-rw-r--r--tests/t301/debian/compat1
-rw-r--r--tests/t301/debian/control18
-rw-r--r--tests/t301/debian/copyright2
-rw-r--r--tests/t301/debian/py3dist-overrides5
-rw-r--r--tests/t301/debian/python3-foo.pydist1
-rwxr-xr-xtests/t301/debian/rules25
-rw-r--r--tests/t301/debian/source/format1
-rw-r--r--tests/t301/lib/foo/__init__.py1
-rw-r--r--tests/t301/lib/foo/bar/__init__.py1
-rw-r--r--tests/t301/lib/foo/baz.py1
l---------tests/t301/lib/foo/jquery.js1
-rw-r--r--tests/t301/setup.py17
14 files changed, 94 insertions, 0 deletions
diff --git a/tests/t301/Makefile b/tests/t301/Makefile
new file mode 100644
index 0000000..4be460f
--- /dev/null
+++ b/tests/t301/Makefile
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+check:
+ grep -qe "Depends: .*python3\(:any\)\? (<< 3.9)" debian/python3-foo/DEBIAN/control
+ grep -q "Recommends: .*python3-mako" debian/python3-foo/DEBIAN/control
+ test -f debian/python3-foo/usr/lib/python3/dist-packages/foo/__init__.py
+ test ! -f debian/python3-foo/usr/lib/python3/dist-packages/foo/spam.py
+ grep -q 'py3compile -p python3-foo -V 3\.1-3\.9' debian/python3-foo/DEBIAN/postinst
+ grep -q 'pypy3compile -p python3-foo -V 3\.1-3\.9' debian/python3-foo/DEBIAN/postinst
+ grep -q 'py3clean -p python3-foo\s*$$' debian/python3-foo/DEBIAN/prerm
+
+clean:
+ ./debian/rules clean
+ rm -rf lib/Foo.egg-info
diff --git a/tests/t301/debian/changelog b/tests/t301/debian/changelog
new file mode 100644
index 0000000..0f9a168
--- /dev/null
+++ b/tests/t301/debian/changelog
@@ -0,0 +1,5 @@
+foo (0.1.1) unstable; urgency=low
+
+ * Initial release
+
+ -- Piotr Ożarowski <piotr@debian.org> Sat, 27 Feb 2010 20:42:17 +0100
diff --git a/tests/t301/debian/compat b/tests/t301/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/tests/t301/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/tests/t301/debian/control b/tests/t301/debian/control
new file mode 100644
index 0000000..fc18d76
--- /dev/null
+++ b/tests/t301/debian/control
@@ -0,0 +1,18 @@
+Source: foo
+Section: python
+Priority: optional
+Maintainer: Piotr Ożarowski <piotr@debian.org>
+Build-Depends: debhelper (>= 7.0.50~), python3-all
+Standards-Version: 3.9.0
+X-Python3-Version: >= 3.1, << 3.9
+
+Architecture: all
+Package: python3-foo
+Depends: ${python3:Depends}, ${misc:Depends}
+Recommends: ${python3:Recommends}
+Suggests: ${python3:Suggests}
+Enhances: ${python3:Enhances}
+Breaks: ${python3:Breaks}
+Provides: ${python3:Provides}
+Description: foo to rule them all
+ example package #1
diff --git a/tests/t301/debian/copyright b/tests/t301/debian/copyright
new file mode 100644
index 0000000..6382944
--- /dev/null
+++ b/tests/t301/debian/copyright
@@ -0,0 +1,2 @@
+The Debian packaging is © 2010, Piotr Ożarowski <piotr@debian.org> and
+is licensed under the MIT License.
diff --git a/tests/t301/debian/py3dist-overrides b/tests/t301/debian/py3dist-overrides
new file mode 100644
index 0000000..ab3ccb8
--- /dev/null
+++ b/tests/t301/debian/py3dist-overrides
@@ -0,0 +1,5 @@
+Mako python3-mako (>= 0.2)
+SQLAlchemy python3-sqlalchemy (>= 0.6)
+Foo python3-foo
+Bar python3-bar
+Baz \ No newline at end of file
diff --git a/tests/t301/debian/python3-foo.pydist b/tests/t301/debian/python3-foo.pydist
new file mode 100644
index 0000000..82849da
--- /dev/null
+++ b/tests/t301/debian/python3-foo.pydist
@@ -0,0 +1 @@
+SQLAlchemy 3.2- python3-sqlalchemy; PEP386 s/^/1:/
diff --git a/tests/t301/debian/rules b/tests/t301/debian/rules
new file mode 100755
index 0000000..9c1bdff
--- /dev/null
+++ b/tests/t301/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+%:
+ dh $@ --buildsystem=python_distutils
+
+override_dh_auto_install:
+ python3 setup.py install --root=debian/python3-foo/
+
+override_dh_install:
+ dh_install
+ find debian/ -name jquery.js -exec \
+ ln -fs /usr/share/javascript/jquery/jquery.js '{}' \;
+ DH_VERBOSE=1 ../../dh_python3\
+ --depends 'SQLAlchemy >= 0.6.1'\
+ --recommends Mako\
+ --suggests 'Foo >= 0.1'\
+ --suggests 'bar >= 1.0'
+
+clean:
+ rm -rf build
+ dh clean
+
+override_dh_auto_build:
+
+override_dh_auto_clean:
+ #python3 setup.py clean
diff --git a/tests/t301/debian/source/format b/tests/t301/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/tests/t301/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/tests/t301/lib/foo/__init__.py b/tests/t301/lib/foo/__init__.py
new file mode 100644
index 0000000..9df03f8
--- /dev/null
+++ b/tests/t301/lib/foo/__init__.py
@@ -0,0 +1 @@
+print("you just imported foo from %s" % __file__)
diff --git a/tests/t301/lib/foo/bar/__init__.py b/tests/t301/lib/foo/bar/__init__.py
new file mode 100644
index 0000000..669df66
--- /dev/null
+++ b/tests/t301/lib/foo/bar/__init__.py
@@ -0,0 +1 @@
+print("you just imported foo.bar from %s" % __file__)
diff --git a/tests/t301/lib/foo/baz.py b/tests/t301/lib/foo/baz.py
new file mode 100644
index 0000000..934dcfe
--- /dev/null
+++ b/tests/t301/lib/foo/baz.py
@@ -0,0 +1 @@
+print("you just imported foo.baz from %s" % __file__)
diff --git a/tests/t301/lib/foo/jquery.js b/tests/t301/lib/foo/jquery.js
new file mode 120000
index 0000000..b77fd86
--- /dev/null
+++ b/tests/t301/lib/foo/jquery.js
@@ -0,0 +1 @@
+/usr/share/javascript/jquery/jquery.js \ No newline at end of file
diff --git a/tests/t301/setup.py b/tests/t301/setup.py
new file mode 100644
index 0000000..bb7f37d
--- /dev/null
+++ b/tests/t301/setup.py
@@ -0,0 +1,17 @@
+#! /usr/bin/python3
+from distutils.core import setup
+
+setup(name='Foo',
+ version='0.2',
+ description="package with public modules only",
+ long_description="TODO",
+ keywords='foo bar baz',
+ author='Piotr Ożarowski',
+ author_email='piotr@debian.org',
+ url='http://www.debian.org/',
+ license='MIT',
+ packages=['foo'],
+ package_dir={'foo': 'lib/foo'},
+ package_data={'foo': ['jquery.js']},
+ zip_safe=False,
+)