summaryrefslogtreecommitdiffstats
path: root/tests/t302/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/t302/setup.py
parentInitial commit. (diff)
downloaddh-python-upstream.tar.xz
dh-python-upstream.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t302/setup.py')
-rwxr-xr-xtests/t302/setup.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/t302/setup.py b/tests/t302/setup.py
new file mode 100755
index 0000000..1208046
--- /dev/null
+++ b/tests/t302/setup.py
@@ -0,0 +1,13 @@
+#! /usr/bin/python3
+from distutils.core import setup, Extension
+
+setup(name='Foo',
+ version='0.1',
+ description="package with Python extension",
+ author='Piotr Ożarowski',
+ author_email='piotr@debian.org',
+ url='http://www.debian.org/',
+ ext_modules=[Extension('foo/bar', ['lib/bar.c'])],
+ #py_modules=['package'],
+ packages=['foo'],
+ package_dir={'foo': 'lib'})