summaryrefslogtreecommitdiffstats
path: root/tests/ta01/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/ta01/debian/rules
parentInitial commit. (diff)
downloaddh-python-upstream.tar.xz
dh-python-upstream.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/ta01/debian/rules')
-rwxr-xr-xtests/ta01/debian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/ta01/debian/rules b/tests/ta01/debian/rules
new file mode 100755
index 0000000..e53f0aa
--- /dev/null
+++ b/tests/ta01/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=foo
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ ../../pybuild --build --verbose
+
+override_dh_auto_install:
+ ../../pybuild --install
+
+override_dh_auto_test:
+ ../../pybuild --test
+
+override_dh_auto_clean:
+ ../../pybuild --clean --verbose
+ rm -rf .pybuild foo.egg-info
+
+override_dh_installinit:
+ DH_VERBOSE=1 ../../dh_python3
+ dh_installinit
+
+override_dh_python3:
+ # ignore any system dh_python3
+
+before-pybuild-autopkgtest:
+ echo $(PYBUILD_AUTOPKGTEST) > marker-PYBUILD_AUTOPKGTEST
+ touch marker-before-pybuild-autopkgtest
+
+after-pybuild-autopkgtest:
+ touch marker-after-pybuild-autopkgtest