summaryrefslogtreecommitdiffstats
path: root/tests/tpb06
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 16:08:06 +0000
commitba6d96469df143b52295f8e79da648bf8a597407 (patch)
tree5ea0c3374f5c53209ad02008dcdddfc8ccae92e5 /tests/tpb06
parentInitial commit. (diff)
downloaddh-python-upstream.tar.xz
dh-python-upstream.zip
Adding upstream version 5.20230130+deb12u1.upstream/5.20230130+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/tpb06')
-rw-r--r--tests/tpb06/LICENSE17
-rw-r--r--tests/tpb06/Makefile20
-rw-r--r--tests/tpb06/debian/changelog5
-rw-r--r--tests/tpb06/debian/control15
-rw-r--r--tests/tpb06/debian/copyright2
-rwxr-xr-xtests/tpb06/debian/rules26
-rw-r--r--tests/tpb06/debian/source/format1
-rw-r--r--tests/tpb06/foo/__init__.py4
-rw-r--r--tests/tpb06/foo/ext.c0
-rw-r--r--tests/tpb06/foo/test_foo.py13
-rw-r--r--tests/tpb06/man/foo.18
-rw-r--r--tests/tpb06/pyproject.toml3
-rw-r--r--tests/tpb06/setup.cfg21
-rw-r--r--tests/tpb06/setup.py12
14 files changed, 147 insertions, 0 deletions
diff --git a/tests/tpb06/LICENSE b/tests/tpb06/LICENSE
new file mode 100644
index 0000000..5996299
--- /dev/null
+++ b/tests/tpb06/LICENSE
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/tests/tpb06/Makefile b/tests/tpb06/Makefile
new file mode 100644
index 0000000..285fe83
--- /dev/null
+++ b/tests/tpb06/Makefile
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+DI=debian/python3-foo/usr/lib/python3/dist-packages/foo-0.1.dist-info
+
+check:
+ test -f debian/python3-foo/usr/lib/python3/dist-packages/foo/__init__.py
+ grep -q ^foo/__init__.py, $(DI)/RECORD
+ test ! -f $(DI)/direct_url.json
+ grep -L ^foo-0.1.dist-info/direct_url.json, $(DI)/RECORD | grep -q RECORD
+ grep -q 'Depends:.*python3-tomli' debian/python3-foo/DEBIAN/control
+ grep -q 'Depends:.*python3-importlib-metadata \| python3 (>> 3\.5)' debian/python3-foo/DEBIAN/control
+ grep -L 'Depends:.*tox' debian/python3-foo/DEBIAN/control | grep -q control
+ find .pybuild -name test-executed | grep -q test-executed
+ grep -q usr/bin/python3$$ debian/python3-foo/usr/bin/foo
+ find debian/python3-foo/usr/lib/python3/dist-packages/ -name LICENSE | { ! grep -q LICENSE; }
+ test -f debian/python3-foo/usr/share/man/man1/foo.1.gz
+
+clean:
+ ./debian/rules clean
diff --git a/tests/tpb06/debian/changelog b/tests/tpb06/debian/changelog
new file mode 100644
index 0000000..322011c
--- /dev/null
+++ b/tests/tpb06/debian/changelog
@@ -0,0 +1,5 @@
+foo (1.2.3) unstable; urgency=low
+
+ * Initial release
+
+ -- Piotr Ozarowski <piotr@debian.org> Tue, 02 Jul 2013 11:02:06 +0200
diff --git a/tests/tpb06/debian/control b/tests/tpb06/debian/control
new file mode 100644
index 0000000..dec1e1f
--- /dev/null
+++ b/tests/tpb06/debian/control
@@ -0,0 +1,15 @@
+Source: foo
+Section: python
+Priority: optional
+Maintainer: Piotr Ożarowski <piotr@debian.org>
+Build-Depends: debhelper-compat (= 12)
+ , python3-all
+ , python3-setuptools
+ , pybuild-plugin-pyproject
+Standards-Version: 3.9.4
+
+Package: python3-foo
+Architecture: any
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: package with public CPython modules
+ example package #1
diff --git a/tests/tpb06/debian/copyright b/tests/tpb06/debian/copyright
new file mode 100644
index 0000000..f96adde
--- /dev/null
+++ b/tests/tpb06/debian/copyright
@@ -0,0 +1,2 @@
+The Debian packaging is © 2013, Piotr Ożarowski <piotr@debian.org> and
+is licensed under the MIT License.
diff --git a/tests/tpb06/debian/rules b/tests/tpb06/debian/rules
new file mode 100755
index 0000000..db68934
--- /dev/null
+++ b/tests/tpb06/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=foo
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ ../../pybuild --build --verbose
+
+override_dh_auto_install:
+ ../../pybuild --install
+
+override_dh_auto_test:
+ ../../pybuild --test
+
+override_dh_auto_clean:
+ ../../pybuild --clean --verbose
+ rm -rf .pybuild foo.egg-info
+
+override_dh_installinit:
+ DH_VERBOSE=1 ../../dh_python3
+ dh_installinit
+
+override_dh_python3:
+ # ignore any system dh_python3
diff --git a/tests/tpb06/debian/source/format b/tests/tpb06/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/tests/tpb06/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/tests/tpb06/foo/__init__.py b/tests/tpb06/foo/__init__.py
new file mode 100644
index 0000000..b3b7945
--- /dev/null
+++ b/tests/tpb06/foo/__init__.py
@@ -0,0 +1,4 @@
+"""An amazing sample package!"""
+
+def main():
+ print("Hello")
diff --git a/tests/tpb06/foo/ext.c b/tests/tpb06/foo/ext.c
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/tpb06/foo/ext.c
diff --git a/tests/tpb06/foo/test_foo.py b/tests/tpb06/foo/test_foo.py
new file mode 100644
index 0000000..926af30
--- /dev/null
+++ b/tests/tpb06/foo/test_foo.py
@@ -0,0 +1,13 @@
+import os
+from unittest import TestCase
+import subprocess
+
+
+class RequiredTest(TestCase):
+ def test_tests_are_executed(self):
+ open('test-executed', 'w').close()
+
+ def test_entry_point_executed(self):
+ path, _, __ = os.environ['PATH'].partition(":")
+ assert path.endswith("/scripts")
+ subprocess.run('foo', check=True)
diff --git a/tests/tpb06/man/foo.1 b/tests/tpb06/man/foo.1
new file mode 100644
index 0000000..3bf5dce
--- /dev/null
+++ b/tests/tpb06/man/foo.1
@@ -0,0 +1,8 @@
+.TH foo 1 "December 5 2022"
+.SH NAME
+foo \- An example
+.SH SYNOPSIS
+.B foo
+.SH DESCRIPTION
+.B foo
+says hi.
diff --git a/tests/tpb06/pyproject.toml b/tests/tpb06/pyproject.toml
new file mode 100644
index 0000000..9787c3b
--- /dev/null
+++ b/tests/tpb06/pyproject.toml
@@ -0,0 +1,3 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+build-backend = "setuptools.build_meta"
diff --git a/tests/tpb06/setup.cfg b/tests/tpb06/setup.cfg
new file mode 100644
index 0000000..fbd051b
--- /dev/null
+++ b/tests/tpb06/setup.cfg
@@ -0,0 +1,21 @@
+[metadata]
+name = foo
+version = 0.1
+description = My package description
+long_description = My long description
+license = Expat
+
+[options]
+zip_safe = False
+packages = find:
+install_requires =
+ tomli
+ importlib-metadata; python_version<'3.5'
+
+[options.entry_points]
+console_scripts =
+ foo = foo:main
+
+[options.data_files]
+share/man/man1 =
+ man/foo.1
diff --git a/tests/tpb06/setup.py b/tests/tpb06/setup.py
new file mode 100644
index 0000000..de0d34b
--- /dev/null
+++ b/tests/tpb06/setup.py
@@ -0,0 +1,12 @@
+from setuptools import setup, Extension
+
+setup_args = dict(
+ ext_modules = [
+ Extension(
+ 'foo.ext',
+ ['foo/ext.c'],
+ py_limited_api = True,
+ )
+ ]
+)
+setup(**setup_args)