summaryrefslogtreecommitdiffstats
path: root/tests/t303/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t303/Makefile')
-rw-r--r--tests/t303/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/t303/Makefile b/tests/t303/Makefile
new file mode 100644
index 0000000..9f2c71b
--- /dev/null
+++ b/tests/t303/Makefile
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+check:
+ test -f debian/python3-foo/usr/lib/python3/dist-packages/foo.py
+ test ! -d debian/python3-foo/usr/lib/python3.*/site-packages
+ grep -q 'py3compile -p python3-foo\s*$$' debian/python3-foo/DEBIAN/postinst
+ grep -q 'pypy3compile -p python3-foo\s*||\s*true$$' debian/python3-foo/DEBIAN/postinst
+ grep -q 'py3clean -p python3-foo\s*$$' debian/python3-foo/DEBIAN/prerm
+
+clean:
+ ./debian/rules clean