summaryrefslogtreecommitdiffstats
path: root/tests/tpb04
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tpb04')
-rw-r--r--tests/tpb04/Makefile10
-rw-r--r--tests/tpb04/_foo.c0
-rw-r--r--tests/tpb04/debian/changelog5
-rw-r--r--tests/tpb04/debian/control23
-rw-r--r--tests/tpb04/debian/copyright2
-rwxr-xr-xtests/tpb04/debian/rules27
-rw-r--r--tests/tpb04/debian/source/format1
-rw-r--r--tests/tpb04/foo.py1
-rw-r--r--tests/tpb04/setup.cfg5
-rw-r--r--tests/tpb04/setup.py9
-rw-r--r--tests/tpb04/test_foo.py6
-rw-r--r--tests/tpb04/tox.ini6
12 files changed, 95 insertions, 0 deletions
diff --git a/tests/tpb04/Makefile b/tests/tpb04/Makefile
new file mode 100644
index 0000000..d1b6324
--- /dev/null
+++ b/tests/tpb04/Makefile
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+include ../common.mk
+
+check:
+ test -f debian/python3-foo/usr/lib/python3/dist-packages/foo.py
+ test -f debian/python3-foo-ext/usr/lib/python3/dist-packages/_foo.abi3.so
+ test -e test-executed
+
+clean:
+ ./debian/rules clean
diff --git a/tests/tpb04/_foo.c b/tests/tpb04/_foo.c
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/tpb04/_foo.c
diff --git a/tests/tpb04/debian/changelog b/tests/tpb04/debian/changelog
new file mode 100644
index 0000000..322011c
--- /dev/null
+++ b/tests/tpb04/debian/changelog
@@ -0,0 +1,5 @@
+foo (1.2.3) unstable; urgency=low
+
+ * Initial release
+
+ -- Piotr Ozarowski <piotr@debian.org> Tue, 02 Jul 2013 11:02:06 +0200
diff --git a/tests/tpb04/debian/control b/tests/tpb04/debian/control
new file mode 100644
index 0000000..f0643cf
--- /dev/null
+++ b/tests/tpb04/debian/control
@@ -0,0 +1,23 @@
+Source: foo
+Section: python
+Priority: optional
+Maintainer: Piotr Ożarowski <piotr@debian.org>
+Build-Depends: debhelper-compat (= 12)
+ , python3-all-dev
+ , python3-setuptools
+ , python3-tomli
+ , tox
+# , dh-python
+Standards-Version: 3.9.4
+
+Package: python3-foo
+Architecture: all
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: package with public CPython modules
+ example package #1
+
+Package: python3-foo-ext
+Architecture: any
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: package with public CPython extensions
+ example package #2
diff --git a/tests/tpb04/debian/copyright b/tests/tpb04/debian/copyright
new file mode 100644
index 0000000..f96adde
--- /dev/null
+++ b/tests/tpb04/debian/copyright
@@ -0,0 +1,2 @@
+The Debian packaging is © 2013, Piotr Ożarowski <piotr@debian.org> and
+is licensed under the MIT License.
diff --git a/tests/tpb04/debian/rules b/tests/tpb04/debian/rules
new file mode 100755
index 0000000..1a4e00b
--- /dev/null
+++ b/tests/tpb04/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=foo
+export PYBUILD_EXT_DESTDIR_python3=debian/python3-foo-ext
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ ../../pybuild --build
+
+override_dh_auto_install:
+ ../../pybuild --install
+
+override_dh_auto_test:
+ ../../pybuild --test --test-tox --test-args=-v
+
+override_dh_auto_clean:
+ ../../pybuild --clean
+ rm -rf .pybuild .tox foo.egg-info test-executed
+
+override_dh_installinit:
+ DH_VERBOSE=1 ../../dh_python3
+ dh_installinit
+
+override_dh_python3:
+ # ignore any system dh_python3
diff --git a/tests/tpb04/debian/source/format b/tests/tpb04/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/tests/tpb04/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/tests/tpb04/foo.py b/tests/tpb04/foo.py
new file mode 100644
index 0000000..810c96e
--- /dev/null
+++ b/tests/tpb04/foo.py
@@ -0,0 +1 @@
+"foo"
diff --git a/tests/tpb04/setup.cfg b/tests/tpb04/setup.cfg
new file mode 100644
index 0000000..3ff1e35
--- /dev/null
+++ b/tests/tpb04/setup.cfg
@@ -0,0 +1,5 @@
+[metadata]
+name = foo
+
+[options]
+py_modules = foo
diff --git a/tests/tpb04/setup.py b/tests/tpb04/setup.py
new file mode 100644
index 0000000..e922974
--- /dev/null
+++ b/tests/tpb04/setup.py
@@ -0,0 +1,9 @@
+from setuptools import setup, Extension
+
+setup(ext_modules=[
+ Extension(
+ '_foo',
+ ['_foo.c'],
+ py_limited_api = True,
+ )
+])
diff --git a/tests/tpb04/test_foo.py b/tests/tpb04/test_foo.py
new file mode 100644
index 0000000..bbe6954
--- /dev/null
+++ b/tests/tpb04/test_foo.py
@@ -0,0 +1,6 @@
+from unittest import TestCase
+
+
+class RequiredTest(TestCase):
+ def test_tests_are_executed(self):
+ open('test-executed', 'w').close()
diff --git a/tests/tpb04/tox.ini b/tests/tpb04/tox.ini
new file mode 100644
index 0000000..08858b5
--- /dev/null
+++ b/tests/tpb04/tox.ini
@@ -0,0 +1,6 @@
+[tox]
+envlist = py39
+
+[testenv]
+deps = tomli
+commands = python -m unittest discover