summaryrefslogtreecommitdiffstats
path: root/tests/tpb07/bar
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tpb07/bar')
-rw-r--r--tests/tpb07/bar/LICENSE17
-rw-r--r--tests/tpb07/bar/bar/__init__.py4
-rw-r--r--tests/tpb07/bar/pyproject.toml3
-rw-r--r--tests/tpb07/bar/setup.cfg17
4 files changed, 41 insertions, 0 deletions
diff --git a/tests/tpb07/bar/LICENSE b/tests/tpb07/bar/LICENSE
new file mode 100644
index 0000000..5996299
--- /dev/null
+++ b/tests/tpb07/bar/LICENSE
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/tests/tpb07/bar/bar/__init__.py b/tests/tpb07/bar/bar/__init__.py
new file mode 100644
index 0000000..717b184
--- /dev/null
+++ b/tests/tpb07/bar/bar/__init__.py
@@ -0,0 +1,4 @@
+"""An amazing sample package!"""
+
+def main():
+ print("Hello I am bar")
diff --git a/tests/tpb07/bar/pyproject.toml b/tests/tpb07/bar/pyproject.toml
new file mode 100644
index 0000000..9787c3b
--- /dev/null
+++ b/tests/tpb07/bar/pyproject.toml
@@ -0,0 +1,3 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+build-backend = "setuptools.build_meta"
diff --git a/tests/tpb07/bar/setup.cfg b/tests/tpb07/bar/setup.cfg
new file mode 100644
index 0000000..296c419
--- /dev/null
+++ b/tests/tpb07/bar/setup.cfg
@@ -0,0 +1,17 @@
+[metadata]
+name = bar
+version = 0.1
+description = My package description
+long_description = My long description
+license = Expat
+
+[options]
+zip_safe = False
+packages = find:
+install_requires =
+ tomli
+ importlib-metadata; python_version<'3.5'
+
+[options.entry_points]
+console_scripts =
+ bar = bar:main