summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:21:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:21:36 +0000
commitbeeaba90c96877f915e8fd9e460518e01a426f2a (patch)
tree562e5ff7ed2412b9d9d1da55d00ad41b74c2914f /debian/rules
parentAdding upstream version 3.4. (diff)
downloaddmidecode-beeaba90c96877f915e8fd9e460518e01a426f2a.tar.xz
dmidecode-beeaba90c96877f915e8fd9e460518e01a426f2a.zip
Adding debian version 3.4-1.debian/3.4-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..dd31875
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND = -fPIE
+export DEB_LDFLAGS_MAINT_APPEND = -fPIE -pie
+
+
+include /usr/share/dpkg/architecture.mk
+ifeq ($(origin CC),default)
+CC = $(DEB_HOST_GNU_TYPE)-gcc
+endif
+
+%:
+ dh ${@}
+
+override_dh_auto_build:
+ dh_auto_build -- CC=$(CC) CFLAGS="$(CFLAGS) $(CPPFLAGS) -Os -ansi" LDFLAGS="$(LDFLAGS)"
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr
+
+ # remove useless files
+ rm -f debian/tmp/usr/share/doc/dmidecode/CHANGELOG
+ rm -f debian/tmp/usr/share/doc/dmidecode/README