summaryrefslogtreecommitdiffstats
path: root/src/replication/aggregator/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:51:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:51:24 +0000
commitf7548d6d28c313cf80e6f3ef89aed16a19815df1 (patch)
treea3f6f2a3f247293bee59ecd28e8cd8ceb6ca064a /src/replication/aggregator/Makefile.am
parentInitial commit. (diff)
downloaddovecot-upstream.tar.xz
dovecot-upstream.zip
Adding upstream version 1:2.3.19.1+dfsg1.upstream/1%2.3.19.1+dfsg1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/replication/aggregator/Makefile.am')
-rw-r--r--src/replication/aggregator/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/replication/aggregator/Makefile.am b/src/replication/aggregator/Makefile.am
new file mode 100644
index 0000000..a0b3501
--- /dev/null
+++ b/src/replication/aggregator/Makefile.am
@@ -0,0 +1,29 @@
+pkglibexecdir = $(libexecdir)/dovecot
+
+pkglibexec_PROGRAMS = aggregator
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-settings \
+ -I$(top_srcdir)/src/lib-auth \
+ -I$(top_srcdir)/src/lib-master \
+ -I$(top_srcdir)/src/replication \
+ -DPKG_STATEDIR=\""$(statedir)"\" \
+ $(BINARY_CFLAGS)
+
+aggregator_LDFLAGS = -export-dynamic \
+ $(BINARY_LDFLAGS)
+
+aggregator_LDADD = $(LIBDOVECOT)
+aggregator_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+
+aggregator_SOURCES = \
+ aggregator.c \
+ aggregator-settings.c \
+ notify-connection.c \
+ replicator-connection.c
+
+noinst_HEADERS = \
+ aggregator-settings.h \
+ notify-connection.h \
+ replicator-connection.h