summaryrefslogtreecommitdiffstats
path: root/src/replication/replicator/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:51:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:51:24 +0000
commitf7548d6d28c313cf80e6f3ef89aed16a19815df1 (patch)
treea3f6f2a3f247293bee59ecd28e8cd8ceb6ca064a /src/replication/replicator/Makefile.am
parentInitial commit. (diff)
downloaddovecot-f7548d6d28c313cf80e6f3ef89aed16a19815df1.tar.xz
dovecot-f7548d6d28c313cf80e6f3ef89aed16a19815df1.zip
Adding upstream version 1:2.3.19.1+dfsg1.upstream/1%2.3.19.1+dfsg1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/replication/replicator/Makefile.am')
-rw-r--r--src/replication/replicator/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/replication/replicator/Makefile.am b/src/replication/replicator/Makefile.am
new file mode 100644
index 0000000..a0ac563
--- /dev/null
+++ b/src/replication/replicator/Makefile.am
@@ -0,0 +1,36 @@
+pkglibexecdir = $(libexecdir)/dovecot
+
+pkglibexec_PROGRAMS = replicator
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-settings \
+ -I$(top_srcdir)/src/lib-auth \
+ -I$(top_srcdir)/src/lib-master \
+ -I$(top_srcdir)/src/replication \
+ -DPKG_STATEDIR=\""$(statedir)"\" \
+ $(BINARY_CFLAGS)
+
+replicator_LDFLAGS = -export-dynamic \
+ $(BINARY_LDFLAGS)
+
+replicator_LDADD = $(LIBDOVECOT)
+replicator_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+
+replicator_SOURCES = \
+ doveadm-connection.c \
+ dsync-client.c \
+ replicator.c \
+ replicator-brain.c \
+ replicator-queue.c \
+ replicator-queue-auth.c \
+ replicator-settings.c \
+ notify-connection.c
+
+noinst_HEADERS = \
+ doveadm-connection.h \
+ dsync-client.h \
+ replicator-brain.h \
+ replicator-queue.h \
+ replicator-settings.h \
+ notify-connection.h