summaryrefslogtreecommitdiffstats
path: root/pigeonhole/src/lib-sieve/plugins/mailbox/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pigeonhole/src/lib-sieve/plugins/mailbox/Makefile.am')
-rw-r--r--pigeonhole/src/lib-sieve/plugins/mailbox/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/pigeonhole/src/lib-sieve/plugins/mailbox/Makefile.am b/pigeonhole/src/lib-sieve/plugins/mailbox/Makefile.am
new file mode 100644
index 0000000..b627735
--- /dev/null
+++ b/pigeonhole/src/lib-sieve/plugins/mailbox/Makefile.am
@@ -0,0 +1,26 @@
+noinst_LTLIBRARIES = libsieve_ext_mailbox.la
+
+AM_CPPFLAGS = \
+ -I$(srcdir)/../.. \
+ $(LIBDOVECOT_INCLUDE)
+
+tags = \
+ tag-mailbox-create.c
+
+tests = \
+ tst-mailboxexists.c
+
+libsieve_ext_mailbox_la_SOURCES = \
+ $(tags) \
+ $(tests) \
+ ext-mailbox.c
+
+public_headers = \
+ sieve-ext-mailbox.h
+
+headers = \
+ ext-mailbox-common.h
+
+pkginc_libdir=$(dovecot_pkgincludedir)/sieve
+pkginc_lib_HEADERS = $(public_headers)
+noinst_HEADERS = $(headers)