summaryrefslogtreecommitdiffstats
path: root/src/plugins/mail-lua/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/mail-lua/Makefile.am')
-rw-r--r--src/plugins/mail-lua/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/plugins/mail-lua/Makefile.am b/src/plugins/mail-lua/Makefile.am
new file mode 100644
index 0000000..1698cb4
--- /dev/null
+++ b/src/plugins/mail-lua/Makefile.am
@@ -0,0 +1,32 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-mail \
+ -I$(top_srcdir)/src/lib-index \
+ -I$(top_srcdir)/src/lib-storage \
+ -I$(top_srcdir)/src/lib-lua \
+ $(LUA_CFLAGS)
+
+NOPLUGIN_LDFLAGS =
+
+module_LTLIBRARIES = \
+ lib01_mail_lua_plugin.la
+
+lib01_mail_lua_plugin_la_LDFLAGS = -module -avoid-version $(LUA_LIBS)
+lib01_mail_lua_plugin_la_LIBADD = \
+ ../../lib-storage/libdovecot-storage-lua.la \
+ $(LIBDOVECOT)
+lib01_mail_lua_plugin_la_SOURCES = \
+ mail-lua-plugin.c
+
+pkginc_libdir=$(pkgincludedir)
+pkginc_lib_HEADERS = \
+ mail-lua-plugin.h
+
+test_programs =
+
+check-local:
+ for bin in $(test_programs); do \
+ if ! env $(test_options) $(RUN_TEST) ./$$bin; then exit 1; fi; \
+ done
+
+noinst_PROGRAMS = $(test_programs)