summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:55:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:55:52 +0000
commit90bc39f808c83ce17d12682654d48292ad5ed458 (patch)
treea13ada63ba80b2ea886616cd1fbe12ce36ebcd92 /debian/rules
parentAdding upstream version 0.15. (diff)
downloaddwz-debian.tar.xz
dwz-debian.zip
Adding debian version 0.15-1.debian/0.15-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2299397
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+#DEB_BUILD_OPTIONS := $(DEB_BUILD_OPTIONS) nostrip noopt
+#export DEB_BUILD_OPTIONS
+
+CFLAGS := $(shell dpkg-buildflags --get CPPFLAGS; dpkg-buildflags --get CFLAGS)
+LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
+
+%:
+ dh $@ --parallel --buildsystem=makefile --builddirectory=build
+
+override_dh_auto_configure:
+ rm -rf build
+ mkdir build
+ cd build && ../configure
+
+override_dh_auto_build:
+ dh_auto_build -- CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
+
+override_dh_auto_test:
+ -dh_auto_test