summaryrefslogtreecommitdiffstats
path: root/carl9170fw/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:26:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:26:09 +0000
commit39a0d9019076a29a57a38a817b1830aef0708c11 (patch)
treed839d866a9986b99e90cd600f6874fae2f712be9 /carl9170fw/CMakeLists.txt
parentInitial commit. (diff)
downloadfirmware-nonfree-upstream.tar.xz
firmware-nonfree-upstream.zip
Adding upstream version 20230210.upstream/20230210upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'carl9170fw/CMakeLists.txt')
-rw-r--r--carl9170fw/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/carl9170fw/CMakeLists.txt b/carl9170fw/CMakeLists.txt
new file mode 100644
index 0000000..c017bbb
--- /dev/null
+++ b/carl9170fw/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(carl9170)
+
+#if you don't want the full compiler output, remove the following line
+#set(CMAKE_VERBOSE_MAKEFILE ON)
+
+include("config.cmake")
+
+add_subdirectory(carlfw)
+
+if (CONFIG_CARL9170FW_BUILD_MINIBOOT)
+ add_subdirectory(minifw)
+endif (CONFIG_CARL9170FW_BUILD_MINIBOOT)
+
+if (CONFIG_CARL9170FW_BUILD_TOOLS)
+ add_subdirectory(tools)
+endif (CONFIG_CARL9170FW_BUILD_TOOLS)
+