summaryrefslogtreecommitdiffstats
path: root/carl9170fw/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:26:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:26:09 +0000
commit39a0d9019076a29a57a38a817b1830aef0708c11 (patch)
treed839d866a9986b99e90cd600f6874fae2f712be9 /carl9170fw/tools/CMakeLists.txt
parentInitial commit. (diff)
downloadfirmware-nonfree-upstream.tar.xz
firmware-nonfree-upstream.zip
Adding upstream version 20230210.upstream/20230210upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'carl9170fw/tools/CMakeLists.txt')
-rw-r--r--carl9170fw/tools/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/carl9170fw/tools/CMakeLists.txt b/carl9170fw/tools/CMakeLists.txt
new file mode 100644
index 0000000..51d71fa
--- /dev/null
+++ b/carl9170fw/tools/CMakeLists.txt
@@ -0,0 +1,38 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(tools)
+
+if (CONFIG_CARL9170FW_MAKE_RELEASE)
+ set(CMAKE_BUILD_TYPE Release)
+endif (CONFIG_CARL9170FW_MAKE_RELEASE)
+
+set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/extra)
+
+include(GCCVersion)
+include("../config.cmake")
+
+_COMPILER_DUMPVERSION(_COMPILER_VERSION)
+
+if (("${_COMPILER_VERSION}" VERSION_GREATER 44) OR
+ ("${_COMPILER_VERSION}" VERSION_EQUAL 44))
+
+ include_directories (../include/linux ../include/shared ../include lib include)
+ add_subdirectory(lib)
+ add_subdirectory(src)
+
+ if (CONFIG_CARL9170FW_BUILD_TOOLS_CARLU)
+ find_package(SDL QUIET)
+ find_package(USB-1.0 QUIET)
+
+ if ("${USB-1.0_FOUND}" AND "${SDL_FOUND}")
+ add_subdirectory(carlu)
+ else()
+ if ("${USB-1.0_FOUND}")
+ MESSAGE(ERROR "LibUSB not found\n")
+ endif ("${USB-1.0_FOUND}")
+ if ("${SDL_FOUND}")
+ MESSAGE(ERROR "SDL not found\n")
+ endif ("${SDL_FOUND}")
+ endif ()
+ endif (CONFIG_CARL9170FW_BUILD_TOOLS_CARLU)
+endif ()