summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0002-use-system-tomli.patch23
-rw-r--r--debian/patches/build-with-local-flit_core.patch23
-rw-r--r--debian/patches/debian_installer_allowed_root.patch28
-rw-r--r--debian/patches/series3
4 files changed, 77 insertions, 0 deletions
diff --git a/debian/patches/0002-use-system-tomli.patch b/debian/patches/0002-use-system-tomli.patch
new file mode 100644
index 0000000..5d9fa65
--- /dev/null
+++ b/debian/patches/0002-use-system-tomli.patch
@@ -0,0 +1,23 @@
+From: Scott Kitterman <scott@kitterman.com>
+Date: Thu, 30 Dec 2021 09:10:52 -0500
+Subject: use system tomli in python lt 3_11
+
+Origin: vendor
+Forwarded: not-needed
+---
+ flit_core/flit_core/config.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/flit_core/flit_core/config.py b/flit_core/flit_core/config.py
+index 1292956..3fd0bd5 100644
+--- a/flit_core/flit_core/config.py
++++ b/flit_core/flit_core/config.py
+@@ -11,7 +11,7 @@ try:
+ import tomllib
+ except ImportError:
+ try:
+- from .vendor import tomli as tomllib
++ import tomli as tomllib
+ # Some downstream distributors remove the vendored tomli.
+ # When that is removed, import tomli from the regular location.
+ except ImportError:
diff --git a/debian/patches/build-with-local-flit_core.patch b/debian/patches/build-with-local-flit_core.patch
new file mode 100644
index 0000000..c87a541
--- /dev/null
+++ b/debian/patches/build-with-local-flit_core.patch
@@ -0,0 +1,23 @@
+From: Stefano Rivera <stefanor@debian.org>
+Date: Fri, 2 Sep 2022 13:20:45 +0200
+Subject: Build flit with the local flit_core
+
+Origin: vendor
+Forwarded: not-needed
+---
+ pyproject.toml | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index caeefcd..e1ec281 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,6 +1,7 @@
+ [build-system]
+-requires = ["flit_core >=3.8.0,<4"]
++requires = []
+ build-backend = "flit_core.buildapi"
++backend-path = ["flit_core"]
+
+ [project]
+ name = "flit"
diff --git a/debian/patches/debian_installer_allowed_root.patch b/debian/patches/debian_installer_allowed_root.patch
new file mode 100644
index 0000000..f0257c8
--- /dev/null
+++ b/debian/patches/debian_installer_allowed_root.patch
@@ -0,0 +1,28 @@
+From: Scott Kitterman <scott@kitterman.com>
+Date: Tue, 7 Dec 2021 20:08:04 -0500
+Subject: Short circuit root test for building Debian packages
+
+Origin: vendor
+Forwarded: not-needed
+Last-Update: 2020-04-13
+
+ * Patch install.Installer class not to error out when subclassed as
+ DebianInstaller from dh-python
+---
+ flit/install.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/flit/install.py b/flit/install.py
+index 3ea9a4b..f29326c 100644
+--- a/flit/install.py
++++ b/flit/install.py
+@@ -109,7 +109,8 @@ class Installer(object):
+
+ if (hasattr(os, 'getuid') and (os.getuid() == 0) and
+ (not os.environ.get('FLIT_ROOT_INSTALL'))):
+- raise RootInstallError
++ if type(self).__name__ != 'DebianInstaller':
++ raise RootInstallError
+
+ if user is None:
+ self.user = self._auto_user(python)
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..dde7e6e
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+debian_installer_allowed_root.patch
+0002-use-system-tomli.patch
+build-with-local-flit_core.patch