summaryrefslogtreecommitdiffstats
path: root/src/modules/rlm_sqlcounter/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/modules/rlm_sqlcounter/configure.ac')
-rw-r--r--src/modules/rlm_sqlcounter/configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/modules/rlm_sqlcounter/configure.ac b/src/modules/rlm_sqlcounter/configure.ac
new file mode 100644
index 0000000..ad631b6
--- /dev/null
+++ b/src/modules/rlm_sqlcounter/configure.ac
@@ -0,0 +1,32 @@
+AC_PREREQ([2.68])
+AC_INIT(rlm_sqlcounter.c)
+AC_REVISION($Revision$)
+FR_INIT_MODULE([rlm_sqlcounter])
+
+if test x$with_[]modname != xno; then
+
+ AC_PROG_CC
+ AC_PROG_CPP
+
+ targetname=modname
+else
+ targetname=
+ echo \*\*\* module modname is disabled.
+fi
+
+if test x"$fail" != x""; then
+ if test x"${enable_strict_dependencies}" = x"yes"; then
+ AC_MSG_ERROR([set --without-]modname[ to disable it explicitly.])
+ else
+ AC_MSG_WARN([silently not building ]modname[.])
+ AC_MSG_WARN([FAILURE: ]modname[ requires: $fail.]);
+ targetname=""
+ fi
+fi
+
+mod_ldflags="$SMART_LIBS"
+mod_cflags="$SMART_CPPFLAGS"
+AC_SUBST(mod_ldflags)
+AC_SUBST(mod_cflags)
+AC_SUBST(targetname)
+AC_OUTPUT(all.mk)