summaryrefslogtreecommitdiffstats
path: root/debian/patches/14_version_gettextcat.diff
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 07:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 07:33:14 +0000
commit99db386956013535171c924df0cfc024f2197339 (patch)
tree002b011f06152f99888cabf1cc528c1d53da17a9 /debian/patches/14_version_gettextcat.diff
parentAdding upstream version 3.7.9. (diff)
downloadgnutls28-99db386956013535171c924df0cfc024f2197339.tar.xz
gnutls28-99db386956013535171c924df0cfc024f2197339.zip
Adding debian version 3.7.9-2+deb12u2.debian/3.7.9-2+deb12u2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/14_version_gettextcat.diff')
-rw-r--r--debian/patches/14_version_gettextcat.diff62
1 files changed, 62 insertions, 0 deletions
diff --git a/debian/patches/14_version_gettextcat.diff b/debian/patches/14_version_gettextcat.diff
new file mode 100644
index 0000000..9a566aa
--- /dev/null
+++ b/debian/patches/14_version_gettextcat.diff
@@ -0,0 +1,62 @@
+Description: Version filename of locale data (gnutls30.mo instead of
+ gnutls.mo) This is necessary to make e.g. libgnutls26 and libgnutls28
+ co-installable.
+Author: Andreas Metzler <ametzler@debian.org>
+Last-Update: 2020-09-06
+
+--- a/po/Makevars
++++ b/po/Makevars
+@@ -5,7 +5,7 @@
+ # unlimited permission to use, copy, distribute, and modify it.
+
+ # Usually the message domain is the same as the package name.
+-DOMAIN = $(PACKAGE)
++DOMAIN = $(PACKAGE)30
+
+ # These two variables depend on the location of this directory.
+ subdir = po
+--- a/lib/global.c
++++ b/lib/global.c
+@@ -262,7 +262,7 @@ static int _gnutls_global_init(unsigned
+ }
+
+ #ifdef HAVE_DCGETTEXT
+- bindtextdomain(PACKAGE, LOCALEDIR);
++ bindtextdomain(GNUTLSDOMAIN, LOCALEDIR);
+ #endif
+
+ res = gnutls_crypto_init();
+--- a/configure.ac
++++ b/configure.ac
+@@ -320,6 +320,9 @@ dnl Try the hooks.m4
+ LIBGNUTLS_HOOKS
+ LIBGNUTLS_EXTRA_HOOKS
+
++AC_DEFINE_UNQUOTED([GNUTLSDOMAIN], ["${PACKAGE}${DLL_VERSION}"],
++ [base filename for gettext message catalogue])
++
+ AC_ARG_ENABLE(tests,
+ AS_HELP_STRING([--disable-tests], [don't compile or run any tests]),
+ enable_tests=$enableval, enable_tests=$enable_tools)
+--- a/lib/str.h
++++ b/lib/str.h
+@@ -33,7 +33,7 @@
+
+ #ifdef HAVE_DCGETTEXT
+ # include "gettext.h"
+-# define _(String) dgettext (PACKAGE, String)
++# define _(String) dgettext (GNUTLSDOMAIN, String)
+ # define N_(String) gettext_noop (String)
+ #else
+ # define _(String) String
+--- a/libdane/errors.c
++++ b/libdane/errors.c
+@@ -25,7 +25,7 @@
+
+ /* I18n of error codes. */
+ #include "gettext.h"
+-#define _(String) dgettext (PACKAGE, String)
++#define _(String) dgettext (GNUTLSDOMAIN, String)
+ #define N_(String) gettext_noop (String)
+
+ #define ERROR_ENTRY(desc, name) \