summaryrefslogtreecommitdiffstats
path: root/lib/extras/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/extras/Makefile.am')
-rw-r--r--lib/extras/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/lib/extras/Makefile.am b/lib/extras/Makefile.am
new file mode 100644
index 0000000..7e5274b
--- /dev/null
+++ b/lib/extras/Makefile.am
@@ -0,0 +1,39 @@
+## Process this file with automake to produce Makefile.in
+# Copyright (C) 2002-2012 Free Software Foundation, Inc.
+#
+# Author: Nikos Mavrogiannopoulos
+#
+# This file is part of GnuTLS.
+#
+# The GnuTLS is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public License
+# as published by the Free Software Foundation; either version 3 of
+# the License, or (at your option) any later version.
+#
+# The GnuTLS is distributed in the hope that it will be
+# useful, but WITHOUT ANY WARRANTY; without even the implied warranty
+# of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>
+
+include $(top_srcdir)/lib/common.mk
+
+AM_CPPFLAGS = \
+ -I$(srcdir)/../../gl \
+ -I$(builddir)/../../gl \
+ -I$(srcdir)/../includes \
+ -I$(builddir)/../includes \
+ -I$(builddir)/../../gl \
+ -I$(srcdir)/..
+
+EXTRA_DIST = licenses/CC0
+
+if ENABLE_MINITASN1
+AM_CPPFLAGS += -I$(srcdir)/../minitasn1
+endif
+
+noinst_LTLIBRARIES = libgnutls_extras.la
+
+libgnutls_extras_la_SOURCES = randomart.c randomart.h hex.c hex.h