summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:00:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:00:29 +0000
commitbd6c5aad40a20b2af4a3c885da39fb2a1832eb19 (patch)
tree2e27b2951f096b501301ee8ea221de96cda71cc9 /debian/rules
parentAdding upstream version 3.2.2. (diff)
downloadhtop-bd6c5aad40a20b2af4a3c885da39fb2a1832eb19.tar.xz
htop-bd6c5aad40a20b2af4a3c885da39fb2a1832eb19.zip
Adding debian version 3.2.2-2.debian/3.2.2-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4a8ce7c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+ifeq (linux,$(DEB_HOST_ARCH_OS))
+ ARCH_DEPENDENT_CONFIGURE_PARAMS = \
+ --enable-affinity \
+ --enable-delayacct
+else
+ ARCH_DEPENDENT_CONFIGURE_PARAMS = \
+ --enable-hwloc
+endif
+
+# hurd-i386 can open /proc (nothing there) and /proc/ which works
+ifeq (hurd,$(DEB_HOST_ARCH_OS))
+ ARCH_DEPENDENT_CONFIGURE_PARAMS+= --with-proc=/proc/
+else
+ ARCH_DEPENDENT_CONFIGURE_PARAMS+= --enable-sensors
+endif
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --enable-openvz \
+ --enable-vserver \
+ --enable-unicode \
+ $(ARCH_DEPENDENT_CONFIGURE_PARAMS)