summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:36:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:36:05 +0000
commit8bc37fc67193505a5a346fd2f1bee70476eb3942 (patch)
tree24bc012bd3fa1f2e7cb96ac12c041bafe31b0670 /debian/rules
parentAdding upstream version 1.1.0. (diff)
downloadicingadb-8bc37fc67193505a5a346fd2f1bee70476eb3942.tar.xz
icingadb-8bc37fc67193505a5a346fd2f1bee70476eb3942.zip
Adding debian version 1.1.0-1.debian/1.1.0-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules45
1 files changed, 45 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4208018
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,45 @@
+#!/usr/bin/make -f
+
+export DH_VERBOSE=1
+
+export DH_GOLANG_BUILDPKG=github.com/icinga/icingadb/cmd/icingadb \
+ github.com/icinga/icingadb/cmd/icingadb-migrate
+
+export GO111MODULE=on
+
+include /usr/share/dpkg/pkg-info.mk
+
+BUILD_DATE=$(shell LC_ALL=C date -u "+%d %B %Y" -d "@$(SOURCE_DATE_EPOCH)")
+
+MANPAGES := $(wildcard debian/man/*.*.xml)
+
+%:
+ dh $@ --builddirectory=_build --buildsystem=golang --with=golang
+
+override_dh_clean:
+ dh_clean debian/man/*.8
+
+override_dh_auto_configure:
+ dh_auto_configure
+
+ (mkdir -p _build/pkg && cd _build/pkg && ln -s ../../dependencies/pkg/* .)
+
+override_dh_auto_build:
+ # Create man page from DocBook XML
+ for x in $(MANPAGES) ; do \
+ docbook2x-man --string-param header-3="$(BUILD_DATE)" $$x ; \
+ mv `basename $$x | sed 's/.xml$$//'` `dirname $$x` ; \
+ done
+
+ dh_auto_build
+
+override_dh_auto_install:
+ dh_auto_install -- --no-source
+
+ mv debian/icingadb/usr/bin debian/icingadb/usr/sbin
+
+override_dh_installsystemd:
+ dh_installsystemd --no-enable --no-start
+
+override_dh_compress:
+ dh_compress -X.md