summaryrefslogtreecommitdiffstats
path: root/packaging/debian/README.1st
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/debian/README.1st')
-rw-r--r--packaging/debian/README.1st18
1 files changed, 18 insertions, 0 deletions
diff --git a/packaging/debian/README.1st b/packaging/debian/README.1st
new file mode 100644
index 0000000..9e96470
--- /dev/null
+++ b/packaging/debian/README.1st
@@ -0,0 +1,18 @@
+Building Debian packages
+========================
+
+This is work in progress, please expect build instructions to change any time
+soon. Currently, to build custom Debian or Ubuntu packages, please proceed as
+follows:
+
+```sh
+apt-get install --no-install-recommends \
+ debhelper devscripts build-essential fakeroot libparse-debcontrol-perl
+# Eventually adjust debian/changelog
+cp -a packaging/debian debian
+dpkg-buildpackage -us -uc
+rm -rf debian
+```
+
+Please move to your parent directory (`cd ..`) to find your new Debian packages.
+