summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:42:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:42:52 +0000
commitfaed92035d84b42692971653b9c42af7c0f03c4a (patch)
tree4f750d617ec7b29add862ca187464beb9b23f3fa /debian/rules
parentAdding upstream version 1.2.2. (diff)
downloadicingaweb2-module-cube-faed92035d84b42692971653b9c42af7c0f03c4a.tar.xz
icingaweb2-module-cube-faed92035d84b42692971653b9c42af7c0f03c4a.zip
Adding debian version 1.2.2-1.debian/1.2.2-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f18fe98
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+MODULE := cube
+DEBDIR := debian/icingaweb2-module-$(MODULE)
+
+%:
+ dh ${@}
+
+override_dh_auto_install:
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
+
+ # remove useless files
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name LICENSE -exec rm -f {} \;
+
+ # enable module
+ mkdir -p $(DEBDIR)/etc/icingaweb2/enabledModules
+ ln -s /usr/share/icingaweb2/modules/$(MODULE) $(DEBDIR)/etc/icingaweb2/enabledModules/$(MODULE)