summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:44:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 12:44:37 +0000
commitd010fabfc87c7925603ee180fc325b621c63629d (patch)
tree7647b09f4f26046e0537c64f4135d288abe56167 /debian/rules
parentAdding upstream version 0.10.0. (diff)
downloadicingaweb2-module-idoreports-d010fabfc87c7925603ee180fc325b621c63629d.tar.xz
icingaweb2-module-idoreports-d010fabfc87c7925603ee180fc325b621c63629d.zip
Adding debian version 0.10.0-1.debian/0.10.0-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..6a36f9a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+MODULE := idoreports
+DEBDIR := debian/icingaweb2-module-$(MODULE)
+
+%:
+ dh ${@}
+
+override_dh_auto_install:
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
+
+ # remove useless file
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name LICENSE -exec rm -f {} \;
+
+ # enable module
+ mkdir -p $(DEBDIR)/etc/icingaweb2/enabledModules
+ ln -s /usr/share/icingaweb2/modules/$(MODULE) $(DEBDIR)/etc/icingaweb2/enabledModules/$(MODULE)