summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..37d7860
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+MODULE := x509
+DEBDIR := debian/icingaweb2-module-$(MODULE)
+
+%:
+ dh ${@} --with phpcomposer
+
+override_dh_auto_install:
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
+
+ # remove useless files
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/vendor/dragonmantank
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/vendor -name *.md -exec rm -f {} \;
+
+execute_after_dh_installdocs:
+ rm -f $(DEBDIR)/usr/share/doc/icingaweb2-module-$(MODULE)/02-Installation.md
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/doc
+ rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/README.md
+ rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/LICENSE
+ rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/vendor/composer/LICENSE
+
+ # enable module
+ mkdir -p $(DEBDIR)/etc/icingaweb2/enabledModules
+ ln -s /usr/share/icingaweb2/modules/$(MODULE) $(DEBDIR)/etc/icingaweb2/enabledModules/$(MODULE)