summaryrefslogtreecommitdiffstats
path: root/src/bin/shell/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 11:36:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 11:36:04 +0000
commit040eee1aa49b49df4698d83a05af57c220127fd1 (patch)
treef635435954e6ccde5eee9893889e24f30ca68346 /src/bin/shell/tests/Makefile.am
parentInitial commit. (diff)
downloadisc-kea-040eee1aa49b49df4698d83a05af57c220127fd1.tar.xz
isc-kea-040eee1aa49b49df4698d83a05af57c220127fd1.zip
Adding upstream version 2.2.0.upstream/2.2.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/bin/shell/tests/Makefile.am')
-rw-r--r--src/bin/shell/tests/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/bin/shell/tests/Makefile.am b/src/bin/shell/tests/Makefile.am
new file mode 100644
index 0000000..c1751ec
--- /dev/null
+++ b/src/bin/shell/tests/Makefile.am
@@ -0,0 +1,26 @@
+SUBDIRS = .
+
+# Needed by shell_unittest.py to access python modules like kea_conn.
+TESTS_ENVIRONMENT = PYTHONPATH="$(abs_top_srcdir)/src/bin/shell"
+
+# Python tests
+PYTESTS = shell_unittest.py
+
+# Shell tests
+SHTESTS =
+SHTESTS += basic_auth_tests.sh
+SHTESTS += shell_process_tests.sh
+if CA_TLS_TEST
+SHTESTS += tls_ca_process_tests.sh
+endif
+
+# Run tests on "make check".
+check_SCRIPTS = $(PYTESTS) $(SHTESTS)
+TESTS = $(PYTESTS) $(SHTESTS)
+
+# As with every file generated by ./configure, clean them up when running
+# "make distclean", but not on "make clean".
+DISTCLEANFILES = $(PYTESTS) $(SHTESTS)
+
+# Don't install tests.
+noinst_SCRIPTS = $(PYTESTS) $(SHTESTS)