summaryrefslogtreecommitdiffstats
path: root/src/bin/admin/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/bin/admin/tests/Makefile.am')
-rw-r--r--src/bin/admin/tests/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/bin/admin/tests/Makefile.am b/src/bin/admin/tests/Makefile.am
new file mode 100644
index 0000000..8377ddc
--- /dev/null
+++ b/src/bin/admin/tests/Makefile.am
@@ -0,0 +1,28 @@
+SUBDIRS = data .
+
+# Add to the tarball:
+EXTRA_DIST =
+EXTRA_DIST += dhcpdb_create_1.0.mysql
+EXTRA_DIST += dhcpdb_create_1.0.pgsql
+
+# Shell tests
+SHTESTS =
+SHTESTS += admin_tests.sh
+SHTESTS += memfile_tests.sh
+if HAVE_MYSQL
+SHTESTS += mysql_tests.sh
+endif
+if HAVE_PGSQL
+SHTESTS += pgsql_tests.sh
+endif
+
+# Run tests on "make check".
+check_SCRIPTS = $(SHTESTS)
+TESTS = $(SHTESTS)
+
+# As with every file generated by ./configure, clean them up when running
+# "make distclean", but not on "make clean".
+DISTCLEANFILES = $(SHTESTS)
+
+# Don't install shell tests.
+noinst_SCRIPTS = $(SHTESTS)