summaryrefslogtreecommitdiffstats
path: root/src/bin/keactrl/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/bin/keactrl/tests/Makefile.am')
-rw-r--r--src/bin/keactrl/tests/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/bin/keactrl/tests/Makefile.am b/src/bin/keactrl/tests/Makefile.am
new file mode 100644
index 0000000..355c041
--- /dev/null
+++ b/src/bin/keactrl/tests/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = .
+
+# Shell tests
+SHTESTS = keactrl_tests.sh
+
+# Run tests on "make check".
+check_SCRIPTS = $(SHTESTS)
+TESTS = $(SHTESTS)
+
+# As with every file generated by ./configure, clean them up when running
+# "make distclean", but not on "make clean".
+DISTCLEANFILES = $(SHTESTS)
+
+# Don't install shell tests.
+noinst_SCRIPTS = $(SHTESTS)