summaryrefslogtreecommitdiffstats
path: root/src/bin/shell/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/bin/shell/tests/Makefile.am')
-rw-r--r--src/bin/shell/tests/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/bin/shell/tests/Makefile.am b/src/bin/shell/tests/Makefile.am
new file mode 100644
index 0000000..c1751ec
--- /dev/null
+++ b/src/bin/shell/tests/Makefile.am
@@ -0,0 +1,26 @@
+SUBDIRS = .
+
+# Needed by shell_unittest.py to access python modules like kea_conn.
+TESTS_ENVIRONMENT = PYTHONPATH="$(abs_top_srcdir)/src/bin/shell"
+
+# Python tests
+PYTESTS = shell_unittest.py
+
+# Shell tests
+SHTESTS =
+SHTESTS += basic_auth_tests.sh
+SHTESTS += shell_process_tests.sh
+if CA_TLS_TEST
+SHTESTS += tls_ca_process_tests.sh
+endif
+
+# Run tests on "make check".
+check_SCRIPTS = $(PYTESTS) $(SHTESTS)
+TESTS = $(PYTESTS) $(SHTESTS)
+
+# As with every file generated by ./configure, clean them up when running
+# "make distclean", but not on "make clean".
+DISTCLEANFILES = $(PYTESTS) $(SHTESTS)
+
+# Don't install tests.
+noinst_SCRIPTS = $(PYTESTS) $(SHTESTS)