summaryrefslogtreecommitdiffstats
path: root/src/lib/config/tests/testdata/spec23.spec
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/config/tests/testdata/spec23.spec')
-rw-r--r--src/lib/config/tests/testdata/spec23.spec18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/lib/config/tests/testdata/spec23.spec b/src/lib/config/tests/testdata/spec23.spec
new file mode 100644
index 0000000..6791b6c
--- /dev/null
+++ b/src/lib/config/tests/testdata/spec23.spec
@@ -0,0 +1,18 @@
+{
+ "module_spec": {
+ "module_name": "Spec2",
+ "commands": [
+ {
+ "command_name": "print_message",
+ "command_description": "Print the given message to stdout",
+ "command_args": [ {
+ "item_name": "message",
+ "item_type": "string",
+ "item_optional": false,
+ "item_default": ""
+ } ]
+ }
+ ]
+ }
+}
+