summaryrefslogtreecommitdiffstats
path: root/src/lib/exceptions/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/exceptions/Makefile.am')
-rw-r--r--src/lib/exceptions/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/lib/exceptions/Makefile.am b/src/lib/exceptions/Makefile.am
new file mode 100644
index 0000000..71785b8
--- /dev/null
+++ b/src/lib/exceptions/Makefile.am
@@ -0,0 +1,16 @@
+SUBDIRS = . tests
+
+AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
+AM_CXXFLAGS=$(KEA_CXXFLAGS)
+
+lib_LTLIBRARIES = libkea-exceptions.la
+
+libkea_exceptions_la_SOURCES = exceptions.h exceptions.cc
+libkea_exceptions_la_SOURCES += isc_assert.h
+libkea_exceptions_la_LDFLAGS = -no-undefined -version-info 13:0:0
+
+CLEANFILES = *.gcno *.gcda
+
+libkea_exceptions_includedir = $(pkgincludedir)/exceptions
+libkea_exceptions_include_HEADERS = exceptions.h
+libkea_exceptions_include_HEADERS += isc_assert.h