summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 08:24:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 08:24:23 +0000
commitd367971a59fcf4e5051ae2c5807971b48f5598e1 (patch)
tree794a41e3cdcd9d29725ade20933ebf2c3c36498a /debian/rules
parentAdding upstream version 1.1.0. (diff)
downloadlibbpf-d367971a59fcf4e5051ae2c5807971b48f5598e1.tar.xz
libbpf-d367971a59fcf4e5051ae2c5807971b48f5598e1.zip
Adding debian version 1.1.0-1.debian/1.1.0-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9636311
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND = -Werror=implicit-function-declaration
+include /usr/share/dpkg/pkg-info.mk
+include /usr/share/dpkg/architecture.mk
+
+ifeq (,$(findstring terse,$(DEB_BUILD_OPTIONS)))
+ VERBOSE=1
+endif
+
+%:
+ dh $@ --sourcedirectory=src
+
+override_dh_gencontrol:
+ dh_gencontrol -- -v1:$(DEB_VERSION)
+
+override_dh_makeshlibs:
+ dh_makeshlibs -- -v1:$(DEB_VERSION)
+
+override_dh_auto_build:
+ dh_auto_build -- LIBSUBDIR=lib/$(DEB_HOST_MULTIARCH) V=$(VERBOSE)
+
+override_dh_auto_install:
+ dh_auto_install -- LIBSUBDIR=lib/$(DEB_HOST_MULTIARCH) V=$(VERBOSE)