summaryrefslogtreecommitdiffstats
path: root/.editorconfig
diff options
context:
space:
mode:
Diffstat (limited to '.editorconfig')
-rw-r--r--.editorconfig19
1 files changed, 19 insertions, 0 deletions
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 0000000..391a6cd
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,19 @@
+# EditorConfig is awesome: http://EditorConfig.org
+root = true
+
+[*.{c,h}]
+indent_style = tab
+tab_width = 8
+
+[*.sh]
+indent_style = space
+indent_size = 4
+
+[{.travis.yml,CMakeLists.txt}]
+indent_style = space
+indent_size = 4
+
+[*.md]
+indent_style = space
+indent_size = 2
+max_line_width = 72