summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/Disable-tests-requiring-Internet-access.patch32
-rw-r--r--debian/patches/disable-full-pathnames-in-Doxygen.patch26
-rw-r--r--debian/patches/series2
3 files changed, 60 insertions, 0 deletions
diff --git a/debian/patches/Disable-tests-requiring-Internet-access.patch b/debian/patches/Disable-tests-requiring-Internet-access.patch
new file mode 100644
index 0000000..7589a35
--- /dev/null
+++ b/debian/patches/Disable-tests-requiring-Internet-access.patch
@@ -0,0 +1,32 @@
+From: Lukas Schwaighofer <lukas@schwaighofer.name>
+Date: Sun, 11 Nov 2018 10:09:35 +0100
+Subject: Disable tests requiring Internet access.
+
+Tests requiring Internet access will fail on Debian's autobuilding
+machines.
+
+Forwarded: not-needed
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7e9aa98..12c65a0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -112,13 +112,13 @@ ADD_TEST(test_trie tests/test_trie)
+ ADD_TEST(test_ht_spkitable tests/test_ht_spkitable)
+ ADD_TEST(test_ht_spkitable_locks tests/test_ht_spkitable_locks)
+
+-ADD_TEST(test_live_validation tests/test_live_validation)
++#ADD_TEST(test_live_validation tests/test_live_validation)
+
+ ADD_TEST(test_ipaddr tests/test_ipaddr)
+
+ ADD_TEST(test_getbits tests/test_getbits)
+
+-ADD_TEST(test_dynamic_groups tests/test_dynamic_groups)
++#ADD_TEST(test_dynamic_groups tests/test_dynamic_groups)
+
+ #install lib
+ set (RTRLIB_VERSION_MAJOR 0)
diff --git a/debian/patches/disable-full-pathnames-in-Doxygen.patch b/debian/patches/disable-full-pathnames-in-Doxygen.patch
new file mode 100644
index 0000000..a4e9f88
--- /dev/null
+++ b/debian/patches/disable-full-pathnames-in-Doxygen.patch
@@ -0,0 +1,26 @@
+From: Lukas Schwaighofer <lukas@schwaighofer.name>
+Date: Sat, 11 Sep 2021 15:22:26 +0200
+Subject: disable full pathnames in Doxygen
+
+Full pathnames cause the location of the files at build time to be included in
+the title of the Doxygen pages. This is undesirable as location is different
+for the installed files and it makes builds unreproducible.
+
+Forwarded: not-needed
+---
+ doxygen/Doxyfile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/doxygen/Doxyfile.in b/doxygen/Doxyfile.in
+index a9bef9e..5620eda 100644
+--- a/doxygen/Doxyfile.in
++++ b/doxygen/Doxyfile.in
+@@ -140,7 +140,7 @@ INLINE_INHERITED_MEMB = NO
+ # shortest path that makes the file name unique will be used
+ # The default value is: YES.
+
+-FULL_PATH_NAMES = YES
++FULL_PATH_NAMES = NO
+
+ # The STRIP_FROM_PATH tag can be used to strip a user-defined part of the path.
+ # Stripping is only done if one of the specified strings matches the left-hand
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..675bc3a
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+Disable-tests-requiring-Internet-access.patch
+disable-full-pathnames-in-Doxygen.patch