summaryrefslogtreecommitdiffstats
path: root/doxygen/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doxygen/examples/CMakeLists.txt')
-rw-r--r--doxygen/examples/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/doxygen/examples/CMakeLists.txt b/doxygen/examples/CMakeLists.txt
new file mode 100644
index 0000000..b58f7bf
--- /dev/null
+++ b/doxygen/examples/CMakeLists.txt
@@ -0,0 +1,8 @@
+if(CMAKE_BUILD_TYPE STREQUAL Debug)
+ if(RTRLIB_HAVE_LIBSSH)
+ add_executable(rtr_mgr rtr_mgr.c)
+ target_link_libraries(rtr_mgr rtrlib)
+ add_executable(ssh_tr ssh_tr.c)
+ target_link_libraries(ssh_tr rtrlib_static)
+ endif(RTRLIB_HAVE_LIBSSH)
+endif(CMAKE_BUILD_TYPE STREQUAL Debug)