summaryrefslogtreecommitdiffstats
path: root/debian/patches/0003-set-man-page-date-to-last-changelog.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0003-set-man-page-date-to-last-changelog.patch')
-rw-r--r--debian/patches/0003-set-man-page-date-to-last-changelog.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/patches/0003-set-man-page-date-to-last-changelog.patch b/debian/patches/0003-set-man-page-date-to-last-changelog.patch
new file mode 100644
index 0000000..39d4a19
--- /dev/null
+++ b/debian/patches/0003-set-man-page-date-to-last-changelog.patch
@@ -0,0 +1,20 @@
+Description: Set the date of man pages to the last changelog entry.
+Forwarded: not-needed
+
+--- a/man/man3/Makefile.am
++++ b/man/man3/Makefile.am
+@@ -55,11 +55,14 @@
+ TPM_Malloc.3
+
+ man3_MANS += $(man3_MANS_generated)
++BUILD_DATE ?= $$(dpkg-parsechangelog -S Date -l../../debian/changelog)
++PODDATE = $$(date -u "+%Y-%m-%d" -d "$(BUILD_DATE)")
+
+ %.3 : %.pod
+ @pod2man -r "libtpms" \
+ -c "" \
+ -n $(basename $@) \
++ --date="$(PODDATE)" \
+ --section=3 $< > $@
+
+ EXTRA_DIST = $(man3_MANS) $(man3_PODS)