summaryrefslogtreecommitdiffstats
path: root/drivers/video/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:49:45 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:49:45 +0000
commit2c3c1048746a4622d8c89a29670120dc8fab93c4 (patch)
tree848558de17fb3008cdf4d861b01ac7781903ce39 /drivers/video/Makefile
parentInitial commit. (diff)
downloadlinux-2c3c1048746a4622d8c89a29670120dc8fab93c4.tar.xz
linux-2c3c1048746a4622d8c89a29670120dc8fab93c4.zip
Adding upstream version 6.1.76.upstream/6.1.76
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'drivers/video/Makefile')
-rw-r--r--drivers/video/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/drivers/video/Makefile b/drivers/video/Makefile
new file mode 100644
index 000000000..5bb6b452c
--- /dev/null
+++ b/drivers/video/Makefile
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0
+
+obj-$(CONFIG_APERTURE_HELPERS) += aperture.o
+obj-$(CONFIG_VGASTATE) += vgastate.o
+obj-$(CONFIG_HDMI) += hdmi.o
+
+obj-$(CONFIG_VT) += console/
+obj-$(CONFIG_FB_STI) += console/
+obj-$(CONFIG_LOGO) += logo/
+obj-y += backlight/
+
+obj-y += fbdev/
+
+obj-$(CONFIG_VIDEOMODE_HELPERS) += display_timing.o videomode.o
+ifeq ($(CONFIG_OF),y)
+obj-$(CONFIG_VIDEOMODE_HELPERS) += of_display_timing.o of_videomode.o
+endif