summaryrefslogtreecommitdiffstats
path: root/arch/ia64/install.sh
diff options
context:
space:
mode:
Diffstat (limited to 'arch/ia64/install.sh')
-rwxr-xr-xarch/ia64/install.sh30
1 files changed, 30 insertions, 0 deletions
diff --git a/arch/ia64/install.sh b/arch/ia64/install.sh
new file mode 100755
index 000000000..2d4b66a9f
--- /dev/null
+++ b/arch/ia64/install.sh
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# This file is subject to the terms and conditions of the GNU General Public
+# License. See the file "COPYING" in the main directory of this archive
+# for more details.
+#
+# Copyright (C) 1995 by Linus Torvalds
+#
+# Adapted from code in arch/i386/boot/Makefile by H. Peter Anvin
+#
+# "make install" script for ia64 architecture
+#
+# Arguments:
+# $1 - kernel version
+# $2 - kernel image file
+# $3 - kernel map file
+# $4 - default install path (blank if root directory)
+
+if [ -f $4/vmlinuz ]; then
+ mv $4/vmlinuz $4/vmlinuz.old
+fi
+
+if [ -f $4/System.map ]; then
+ mv $4/System.map $4/System.old
+fi
+
+cat $2 > $4/vmlinuz
+cp $3 $4/System.map
+
+test -x /usr/sbin/elilo && /usr/sbin/elilo