summaryrefslogtreecommitdiffstats
path: root/drivers/hid/i2c-hid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/hid/i2c-hid/Makefile')
-rw-r--r--drivers/hid/i2c-hid/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/drivers/hid/i2c-hid/Makefile b/drivers/hid/i2c-hid/Makefile
new file mode 100644
index 000000000..55bd5e0f3
--- /dev/null
+++ b/drivers/hid/i2c-hid/Makefile
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the I2C input drivers
+#
+
+obj-$(CONFIG_I2C_HID_CORE) += i2c-hid.o
+
+i2c-hid-objs = i2c-hid-core.o
+i2c-hid-$(CONFIG_DMI) += i2c-hid-dmi-quirks.o
+
+obj-$(CONFIG_I2C_HID_ACPI) += i2c-hid-acpi.o
+obj-$(CONFIG_I2C_HID_OF) += i2c-hid-of.o
+obj-$(CONFIG_I2C_HID_OF_ELAN) += i2c-hid-of-elan.o
+obj-$(CONFIG_I2C_HID_OF_GOODIX) += i2c-hid-of-goodix.o