summaryrefslogtreecommitdiffstats
path: root/drivers/net/can/m_can/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/net/can/m_can/Makefile')
-rw-r--r--drivers/net/can/m_can/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/drivers/net/can/m_can/Makefile b/drivers/net/can/m_can/Makefile
new file mode 100644
index 000000000..d717bbc9e
--- /dev/null
+++ b/drivers/net/can/m_can/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the Bosch M_CAN controller driver.
+#
+
+obj-$(CONFIG_CAN_M_CAN) += m_can.o
+obj-$(CONFIG_CAN_M_CAN_PCI) += m_can_pci.o
+obj-$(CONFIG_CAN_M_CAN_PLATFORM) += m_can_platform.o
+obj-$(CONFIG_CAN_M_CAN_TCAN4X5X) += tcan4x5x.o
+
+tcan4x5x-objs :=
+tcan4x5x-objs += tcan4x5x-core.o
+tcan4x5x-objs += tcan4x5x-regmap.o