summaryrefslogtreecommitdiffstats
path: root/drivers/net/ethernet/mscc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/net/ethernet/mscc/Makefile')
-rw-r--r--drivers/net/ethernet/mscc/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/drivers/net/ethernet/mscc/Makefile b/drivers/net/ethernet/mscc/Makefile
new file mode 100644
index 000000000..5d435a565
--- /dev/null
+++ b/drivers/net/ethernet/mscc/Makefile
@@ -0,0 +1,18 @@
+# SPDX-License-Identifier: (GPL-2.0 OR MIT)
+obj-$(CONFIG_MSCC_OCELOT_SWITCH_LIB) += mscc_ocelot_switch_lib.o
+mscc_ocelot_switch_lib-y := \
+ ocelot.o \
+ ocelot_devlink.o \
+ ocelot_flower.o \
+ ocelot_io.o \
+ ocelot_police.o \
+ ocelot_ptp.o \
+ ocelot_stats.o \
+ ocelot_vcap.o \
+ vsc7514_regs.o
+mscc_ocelot_switch_lib-$(CONFIG_BRIDGE_MRP) += ocelot_mrp.o
+obj-$(CONFIG_MSCC_OCELOT_SWITCH) += mscc_ocelot.o
+mscc_ocelot-y := \
+ ocelot_fdma.o \
+ ocelot_net.o \
+ ocelot_vsc7514.o