summaryrefslogtreecommitdiffstats
path: root/src/pcrepp/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:44:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:44:55 +0000
commit5068d34c08f951a7ea6257d305a1627b09a95817 (patch)
tree08213e2be853396a3b07ce15dbe222644dcd9a89 /src/pcrepp/Makefile.am
parentInitial commit. (diff)
downloadlnav-upstream.tar.xz
lnav-upstream.zip
Adding upstream version 0.11.1.upstream/0.11.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/pcrepp/Makefile.am')
-rw-r--r--src/pcrepp/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/pcrepp/Makefile.am b/src/pcrepp/Makefile.am
new file mode 100644
index 0000000..72e8319
--- /dev/null
+++ b/src/pcrepp/Makefile.am
@@ -0,0 +1,33 @@
+
+include $(top_srcdir)/aminclude_static.am
+
+AM_CPPFLAGS = \
+ $(CODE_COVERAGE_CPPFLAGS) \
+ $(PCRE_CFLAGS) \
+ -Wall \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/fmtlib \
+ -I$(top_srcdir)/src/third-party/scnlib/include
+
+AM_LIBS = $(CODE_COVERAGE_LIBS)
+AM_CFLAGS = $(CODE_COVERAGE_CFLAGS)
+AM_CXXFLAGS = $(CODE_COVERAGE_CXXFLAGS)
+
+noinst_LIBRARIES = libpcrepp.a
+
+noinst_HEADERS = \
+ pcre2pp.hh
+
+libpcrepp_a_SOURCES = \
+ pcre2pp.cc
+
+test_pcre2pp_SOURCES = test_pcre2pp.cc
+test_pcre2pp_LDADD = \
+ libpcrepp.a \
+ $(PCRE_LIBS)
+
+check_PROGRAMS = \
+ test_pcre2pp
+
+TESTS = \
+ test_pcre2pp