summaryrefslogtreecommitdiffstats
path: root/src/formats/logfmt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/formats/logfmt/Makefile.am')
-rw-r--r--src/formats/logfmt/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/formats/logfmt/Makefile.am b/src/formats/logfmt/Makefile.am
new file mode 100644
index 0000000..8d1f3ff
--- /dev/null
+++ b/src/formats/logfmt/Makefile.am
@@ -0,0 +1,41 @@
+
+include $(top_srcdir)/aminclude_static.am
+
+AM_CPPFLAGS = \
+ $(CODE_COVERAGE_CPPFLAGS) \
+ -Wall \
+ -I$(top_srcdir)/src/ \
+ -I$(top_srcdir)/src/third-party \
+ -I$(top_srcdir)/src/fmtlib \
+ -I$(top_srcdir)/src/third-party/scnlib/include \
+ $(LIBARCHIVE_CFLAGS) \
+ $(READLINE_CFLAGS) \
+ $(SQLITE3_CFLAGS) \
+ $(LIBCURL_CPPFLAGS)
+
+AM_LIBS = $(CODE_COVERAGE_LIBS)
+AM_CFLAGS = $(CODE_COVERAGE_CFLAGS)
+AM_CXXFLAGS = $(CODE_COVERAGE_CXXFLAGS)
+
+noinst_LIBRARIES = liblogfmt.a
+
+noinst_HEADERS = \
+ logfmt.parser.hh
+
+liblogfmt_a_SOURCES = \
+ logfmt.parser.cc
+
+check_PROGRAMS = \
+ logfmt.parser.test
+
+logfmt_parser_test_SOURCES = \
+ logfmt.parser.test.cc
+
+logfmt_parser_test_LDADD = \
+ liblogfmt.a \
+ $(top_builddir)/src/base/libbase.a \
+ $(top_builddir)/src/pcrepp/libpcrepp.a \
+ $(top_builddir)/src/third-party/scnlib/src/libscnlib.a
+
+TESTS = \
+ logfmt.parser.test