summaryrefslogtreecommitdiffstats
path: root/src/remote/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/remote/CMakeLists.txt')
-rw-r--r--src/remote/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/remote/CMakeLists.txt b/src/remote/CMakeLists.txt
new file mode 100644
index 0000000..a29fbde
--- /dev/null
+++ b/src/remote/CMakeLists.txt
@@ -0,0 +1,5 @@
+add_library(remote STATIC ../config.h.in remote.ssh.cc remote.ssh.hh)
+
+target_include_directories(remote PUBLIC . .. ../fmtlib
+ ${CMAKE_CURRENT_BINARY_DIR}/..)
+target_link_libraries(remote cppfmt pcre::libpcre)