summaryrefslogtreecommitdiffstats
path: root/plugin/feedback/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 18:07:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 18:07:14 +0000
commita175314c3e5827eb193872241446f2f8f5c9d33c (patch)
treecd3d60ca99ae00829c52a6ca79150a5b6e62528b /plugin/feedback/CMakeLists.txt
parentInitial commit. (diff)
downloadmariadb-10.5-a175314c3e5827eb193872241446f2f8f5c9d33c.tar.xz
mariadb-10.5-a175314c3e5827eb193872241446f2f8f5c9d33c.zip
Adding upstream version 1:10.5.12.upstream/1%10.5.12upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'plugin/feedback/CMakeLists.txt')
-rw-r--r--plugin/feedback/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/plugin/feedback/CMakeLists.txt b/plugin/feedback/CMakeLists.txt
new file mode 100644
index 00000000..2103250e
--- /dev/null
+++ b/plugin/feedback/CMakeLists.txt
@@ -0,0 +1,23 @@
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/sql
+ ${PCRE_INCLUDES}
+ ${SSL_INCLUDE_DIRS})
+
+SET(FEEDBACK_SOURCES feedback.cc sender_thread.cc
+ url_base.cc url_http.cc utils.cc)
+
+ADD_DEFINITIONS(${SSL_DEFINES})
+
+INCLUDE (CheckIncludeFiles)
+CHECK_INCLUDE_FILES (netdb.h HAVE_NETDB_H)
+IF(HAVE_NETDB_H)
+ ADD_DEFINITIONS(-DHAVE_NETDB_H)
+ENDIF(HAVE_NETDB_H)
+
+IF(WIN32)
+ SET(MAYBE_STATIC_ONLY STATIC_ONLY)
+ENDIF(WIN32)
+
+MYSQL_ADD_PLUGIN(FEEDBACK ${FEEDBACK_SOURCES}
+ LINK_LIBRARIES ${SSL_LIBRARIES}
+ ${MAYBE_STATIC_ONLY} RECOMPILE_FOR_EMBEDDED DEFAULT)
+