summaryrefslogtreecommitdiffstats
path: root/storage/mroonga/build
diff options
context:
space:
mode:
Diffstat (limited to 'storage/mroonga/build')
-rw-r--r--storage/mroonga/build/Makefile.am2
-rw-r--r--storage/mroonga/build/cmake_modules/Makefile.am2
-rw-r--r--storage/mroonga/build/cmake_modules/ReadFileList.cmake27
-rw-r--r--storage/mroonga/build/makefiles/LC_MESSAGES.am5
-rw-r--r--storage/mroonga/build/makefiles/gettext.am86
-rw-r--r--storage/mroonga/build/makefiles/locale.am12
-rw-r--r--storage/mroonga/build/makefiles/sphinx-build.am17
-rw-r--r--storage/mroonga/build/makefiles/sphinx.am179
8 files changed, 330 insertions, 0 deletions
diff --git a/storage/mroonga/build/Makefile.am b/storage/mroonga/build/Makefile.am
new file mode 100644
index 00000000..506a11dc
--- /dev/null
+++ b/storage/mroonga/build/Makefile.am
@@ -0,0 +1,2 @@
+SUBDIRS = \
+ cmake_modules
diff --git a/storage/mroonga/build/cmake_modules/Makefile.am b/storage/mroonga/build/cmake_modules/Makefile.am
new file mode 100644
index 00000000..83fb0f0c
--- /dev/null
+++ b/storage/mroonga/build/cmake_modules/Makefile.am
@@ -0,0 +1,2 @@
+EXTRA_DIST = \
+ ReadFileList.cmake
diff --git a/storage/mroonga/build/cmake_modules/ReadFileList.cmake b/storage/mroonga/build/cmake_modules/ReadFileList.cmake
new file mode 100644
index 00000000..204f59f6
--- /dev/null
+++ b/storage/mroonga/build/cmake_modules/ReadFileList.cmake
@@ -0,0 +1,27 @@
+# Copyright(C) 2012 Brazil
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License version 2.1 as published by the Free Software Foundation.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1335 USA
+
+macro(read_file_list file_name output_variable)
+ file(READ ${file_name} ${output_variable})
+ # Remove variable declaration at the first line:
+ # "libgroonga_la_SOURCES = \" -> ""
+ string(REGEX REPLACE "^.*=[ \t]*\\\\" ""
+ ${output_variable} "${${output_variable}}")
+ # Remove white spaces: " com.c \\\n com.h \\\n" -> "com.c\\com.h"
+ string(REGEX REPLACE "[ \t\n]" "" ${output_variable} "${${output_variable}}")
+ # Convert string to list: "com.c\\com.h" -> "com.c;com.h"
+ # NOTE: List in CMake is ";" separated string.
+ string(REGEX REPLACE "\\\\" ";" ${output_variable} "${${output_variable}}")
+endmacro()
diff --git a/storage/mroonga/build/makefiles/LC_MESSAGES.am b/storage/mroonga/build/makefiles/LC_MESSAGES.am
new file mode 100644
index 00000000..acfc3da2
--- /dev/null
+++ b/storage/mroonga/build/makefiles/LC_MESSAGES.am
@@ -0,0 +1,5 @@
+BUILT_SOURCES =
+EXTRA_DIST =
+SUFFIXES =
+
+include $(top_srcdir)/build/makefiles/gettext.am
diff --git a/storage/mroonga/build/makefiles/gettext.am b/storage/mroonga/build/makefiles/gettext.am
new file mode 100644
index 00000000..9cea8ce6
--- /dev/null
+++ b/storage/mroonga/build/makefiles/gettext.am
@@ -0,0 +1,86 @@
+include $(top_srcdir)/doc/files.am
+include $(top_srcdir)/build/makefiles/sphinx-build.am
+
+CLEANFILES =
+
+EXTRA_DIST += \
+ $(po_files)
+
+if DOCUMENT_AVAILABLE
+EXTRA_DIST += \
+ $(mo_files)
+endif
+
+if DOCUMENT_BUILDABLE
+BUILT_SOURCES += \
+ mo-build-stamp
+CLEANFILES += \
+ pot-build-stamp \
+ edit-po-build-stamp \
+ mo-build-stamp
+endif
+
+SUFFIXES += .pot .po .mo .edit
+
+.PHONY: gettext update build
+
+.pot.edit:
+ if test -f $*.po; then \
+ msgmerge \
+ --quiet \
+ --sort-by-file \
+ --output-file=$@.tmp \
+ $*.po \
+ $<; \
+ else \
+ msginit \
+ --input=$< \
+ --output-file=$@.tmp \
+ --locale=$(LOCALE) \
+ --no-translator; \
+ fi
+ (echo "# -*- po -*-"; \
+ GREP_OPTIONS= grep -v '^# -\*- po -\*-' $@.tmp | \
+ GREP_OPTIONS= grep -v '^"POT-Creation-Date:') > $@
+ rm $@.tmp
+
+.edit.po:
+ msgcat --no-location --output $@ $<
+
+.po.mo:
+ msgfmt -o $@ $<
+
+if DOCUMENT_BUILDABLE
+update: edit-po-build-stamp
+build: mo-build-stamp
+else
+update:
+build:
+endif
+
+html: build
+man: build
+pdf: build
+
+gettext:
+ rm *.pot || true
+ $(SPHINX_BUILD_COMMAND) -d doctrees -b gettext $(ALLSPHINXOPTS) .
+ xgettext --language Python --output conf.pot \
+ $(top_srcdir)/doc/source/conf.py
+
+pot-build-stamp: $(absolute_source_files)
+ $(MAKE) gettext
+ @touch $@
+
+edit-po-build-stamp: pot-build-stamp
+ $(MAKE) $(edit_po_files)
+ @touch $@
+
+mo_build_stamp_dependencies = edit-po-build-stamp
+if DOCUMENT_BUILDABLE
+mo_build_stamp_dependencies += $(edit_po_files)
+endif
+
+mo-build-stamp: $(mo_build_stamp_dependencies)
+ $(MAKE) $(mo_files)
+ @touch $@
diff --git a/storage/mroonga/build/makefiles/locale.am b/storage/mroonga/build/makefiles/locale.am
new file mode 100644
index 00000000..414c19a7
--- /dev/null
+++ b/storage/mroonga/build/makefiles/locale.am
@@ -0,0 +1,12 @@
+SUBDIRS = LC_MESSAGES
+
+BUILT_SOURCES =
+EXTRA_DIST =
+
+include $(top_srcdir)/build/makefiles/sphinx.am
+
+init:
+ cd LC_MESSAGES && $(MAKE) $@
+
+update-po:
+ cd LC_MESSAGES && $(MAKE) update
diff --git a/storage/mroonga/build/makefiles/sphinx-build.am b/storage/mroonga/build/makefiles/sphinx-build.am
new file mode 100644
index 00000000..57bbcd61
--- /dev/null
+++ b/storage/mroonga/build/makefiles/sphinx-build.am
@@ -0,0 +1,17 @@
+# You can set these variables from the command line.
+DOCTREES_BASE = doctrees
+
+SPHINXOPTS =
+PAPER =
+
+# Internal variables.
+SOURCE_DIR = $(abs_top_srcdir)/doc/source
+PAPEROPT_a4 = -D latex_paper_size=a4
+PAPEROPT_letter = -D latex_paper_size=letter
+ALLSPHINXOPTS = $(PAPEROPT_$(PAPER)) -E $(SPHINXOPTS) $(SOURCE_DIR)
+
+SPHINX_BUILD_COMMAND = \
+ DOCUMENT_VERSION="$(DOCUMENT_VERSION)" \
+ DOCUMENT_VERSION_FULL="$(DOCUMENT_VERSION_FULL)" \
+ LOCALE="$(LOCALE)" \
+ $(SPHINX_BUILD)
diff --git a/storage/mroonga/build/makefiles/sphinx.am b/storage/mroonga/build/makefiles/sphinx.am
new file mode 100644
index 00000000..c68f62e2
--- /dev/null
+++ b/storage/mroonga/build/makefiles/sphinx.am
@@ -0,0 +1,179 @@
+include $(top_srcdir)/doc/files.am
+include $(top_srcdir)/build/makefiles/sphinx-build.am
+
+$(html_files): html-build-stamp
+$(html_files_relative_from_locale_dir): html-build-stamp
+$(man_files): man-build-stamp
+
+am__nobase_dist_doc_locale_DATA_DIST =
+if DOCUMENT_AVAILABLE
+doc_localedir = $(docdir)/$(LOCALE)
+nobase_dist_doc_locale_DATA = \
+ $(html_files_relative_from_locale_dir)
+am__nobase_dist_doc_locale_DATA_DIST += \
+ $(nobase_dist_doc_locale_DATA)
+endif
+
+document_source_files = \
+ $(absolute_source_files) \
+ $(absolute_theme_files) \
+ $(po_files_relative_from_locale_dir) \
+ $(mo_files_relative_from_locale_dir)
+
+required_build_stamps = \
+ html-build-stamp \
+ man-build-stamp \
+ mo-build-stamp
+
+if DOCUMENT_BUILDABLE
+EXTRA_DIST += $(required_build_stamps)
+endif
+
+man_files = \
+ man/$(PACKAGE_NAME).1
+
+generated_files = \
+ $(DOCTREES_BASE) \
+ man \
+ man-build-stamp \
+ html \
+ html-build-stamp \
+ pdf \
+ pdf-build-stamp \
+ dirhtml \
+ dirhtml-build-stamp \
+ pickle \
+ pikcle-build-stamp \
+ json \
+ json-build-stamp \
+ htmlhelp \
+ htmlhelp-build-stamp \
+ qthelp \
+ qthelp-build-stamp \
+ latex \
+ latex-build-stamp \
+ changes \
+ changes-build-stamp \
+ linkcheck \
+ linkcheck-build-stamp \
+ doctest
+
+$(mo_files_relative_from_locale_dir): mo-build-stamp
+
+mo-build-stamp: $(po_files_relative_from_locale_dir)
+ cd LC_MESSAGES && $(MAKE) build
+ @touch $@
+
+if DOCUMENT_BUILDABLE
+clean-local: $(clean_targets) clean-doctrees
+
+clean-doctrees:
+ rm -rf $(DOCTREES_BASE)
+
+maintainer-clean-local:
+ rm -rf -- $(generated_files)
+endif
+
+.PHONY: help
+.PHONY: man clean-man
+.PHONY: html clean-html
+.PHONY: pdf
+.PHONY: dirhtml
+.PHONY: pickle
+.PHONY: json
+.PHONY: htmlhelp
+.PHONY: qthelp
+.PHONY: latex
+.PHONY: changes
+.PHONY: linkcheck
+.PHONY: doctest
+
+if DOCUMENT_BUILDABLE
+help:
+ @echo "Please use \`make <target>' where <target> is one of"
+ @echo " man to make man files"
+ @echo " html to make standalone HTML files"
+ @echo " dirhtml to make HTML files named index.html in directories"
+ @echo " pickle to make pickle files"
+ @echo " json to make JSON files"
+ @echo " htmlhelp to make HTML files and a HTML help project"
+ @echo " qthelp to make HTML files and a qthelp project"
+ @echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
+ @echo " rdoc to make RDoc files"
+ @echo " textile to make Textile files"
+ @echo " changes to make an overview of all changed/added/deprecated items"
+ @echo " linkcheck to check all external links for integrity"
+ @echo " doctest to run all doctests embedded in the documentation (if enabled)"
+
+man: man-build-stamp
+html: html-recursive html-build-stamp
+dirhtml: dirhtml-build-stamp
+pickle: pickle-build-stamp
+json: json-build-stamp
+htmlhelp: htmlhelp-build-stamp
+qthelp: qthelp-build-stamp
+latex: latex-build-stamp
+rdoc: rdoc-build-stamp
+textile: textile-build-stamp
+changes: changes-build-stamp
+linkcheck: linkcheck-build-stamp
+doctest: doctest-build-stamp
+
+clean_targets = \
+ clean-man \
+ clean-html \
+ clean-dirhtml \
+ clean-pickle \
+ clean-json \
+ clean-htmlhelp \
+ clean-qthelp \
+ clean-latex \
+ clean-rdoc \
+ clean-textile \
+ clean-changes \
+ clean-linkcheck \
+ clean-doctest
+
+$(clean_targets):
+ target=`echo $@ | sed -e 's/^clean-//'`; \
+ rm -rf $${target}-build-stamp $${target}
+
+build_stamps = \
+ man-build-stamp \
+ html-build-stamp \
+ dirhtml-build-stamp \
+ pickle-build-stamp \
+ json-build-stamp \
+ htmlhelp-build-stamp \
+ qthelp-build-stamp \
+ latex-build-stamp \
+ rdoc-build-stamp \
+ textile-build-stamp \
+ changes-build-stamp \
+ linkcheck-build-stamp \
+ doctest-build-stamp
+
+$(build_stamps): $(document_source_files)
+ target=`echo $@ | sed -e 's/-build-stamp$$//'`; \
+ $(SPHINX_BUILD_COMMAND) \
+ -Dlanguage=$(LOCALE) \
+ -d $(DOCTREES_BASE)/$${target} \
+ -b $${target} \
+ $(ALLSPHINXOPTS) \
+ $${target}
+ @touch $@
+
+qthelp: qthelp-message
+qthelp-message: qthelp-build-stamp
+ @echo "Build finished; now you can run 'qcollectiongenerator' with the" \
+ ".qhcp project file in qthelp/*, like this:"
+ @echo "# qcollectiongenerator qthelp/groonga.qhcp"
+ @echo "To view the help file:"
+ @echo "# assistant -collectionFile qthelp/groonga.qhc"
+
+latex: latex-message
+latex-message: latex-build-stamp
+ @echo "Build finished; the LaTeX files are in latex/*."
+ @echo "Run \`make all-pdf' or \`make all-ps' in that directory to" \
+ "run these through (pdf)latex."
+endif