summaryrefslogtreecommitdiffstats
path: root/wsrep-lib/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 18:04:16 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 18:04:16 +0000
commita68fb2d8219f6bccc573009600e9f23e89226a5e (patch)
treed742d35d14ae816e99293d2b01face30e9f3a46b /wsrep-lib/src/CMakeLists.txt
parentInitial commit. (diff)
downloadmariadb-10.6-upstream.tar.xz
mariadb-10.6-upstream.zip
Adding upstream version 1:10.6.11.upstream/1%10.6.11upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'wsrep-lib/src/CMakeLists.txt')
-rw-r--r--wsrep-lib/src/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/wsrep-lib/src/CMakeLists.txt b/wsrep-lib/src/CMakeLists.txt
new file mode 100644
index 00000000..d5049e11
--- /dev/null
+++ b/wsrep-lib/src/CMakeLists.txt
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2018 Codership Oy <info@codership.com>
+#
+
+add_library(wsrep-lib
+ client_state.cpp
+ exception.cpp
+ gtid.cpp
+ id.cpp
+ xid.cpp
+ key.cpp
+ logger.cpp
+ provider.cpp
+ seqno.cpp
+ view.cpp
+ server_state.cpp
+ thread.cpp
+ thread_service_v1.cpp
+ tls_service_v1.cpp
+ event_service_v1.cpp
+ transaction.cpp
+ uuid.cpp
+ reporter.cpp
+ allowlist_service_v1.cpp
+ wsrep_provider_v26.cpp)
+target_link_libraries(wsrep-lib wsrep_api_v26 pthread ${WSREP_LIB_LIBDL})